Closed Bug 390454 Opened 14 years ago Closed 14 years ago

Applying overflow-x / overflow-y style(s) to large container div does not render all of content (Windows only)

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 215055

People

(Reporter: mail, Unassigned)

References

()

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007080105 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007080105 Minefield/3.0a7pre

If I apply the overflow-x and/or overflow-y styles to a large container div (which contains lots of content), Firefox stops rendering information at what seems to be a static point in the document.  This can be the top half of a text sentence, which suggests to me that the problem isn't related to the content itself.

Reproducible: Always

Steps to Reproduce:
1. Open the supplied URL.
2. Scroll down to around or just after halfway (in scrollbar terms)
3. The text will just disappear, but you can continue to scroll the 'whitespace'

Actual Results:  
The text will just stop being rendered (sometimes only the top half of the final row of rendered text will be displayed) but you can continue scrolling the 'whitespace'.  Firefox Developer Tools still seem to recognise that elements exist 'behind' the whitespace.

Expected Results:  
All of the content should be rendered to the bottom of the page.

This problem does not occur in recent releases of IE, Opera or Safari on Windows.  Nor does it occur in Firefox 2.0.0.3 or 2.0.0.4 on Linux.
The problem seems to be when either overflow-x or overflow-y have recognised values.  In my example I have incorrectly specified overflow-x as hide rather than hidden, but this is irrelevant as it is ignored anyway.

It seems that if overflow-x / overflow-y is specified as auto or scroll, then the content is rendered incorrectly.  Values of hidden or visible seem to display the content correctly.
This problem still occurring with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008010917. The test.html only rendered correctly, if the value of overflow-x / overflow-y is specified as visible, otherwise the content will be corrupted.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: big-long-large-32767
You need to log in before you can comment on or make changes to this bug.