Opening a reserved filename causes a hang in FF2

RESOLVED DUPLICATE of bug 29079

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 29079
11 years ago
11 years ago

People

(Reporter: Ron, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

1. On my internal website, there is an option to upload a picture file.
2. Upload file with name of "c:\com1.jpg"
3. Close FF
4. Check Processes tab

Actual:
Firefox hangs and additional tabs cannot go to any website.
Closing Firefox will close the browser but there is an instance of firefox.exe still running in processes.

Expected:
Should handle reserved filenames gracefully.
Does not happen on IE7.

Reproducible: Always

Steps to Reproduce:
1. On my internal website, there is an option to upload a picture file.
2. Upload file with name of "c:\com1.jpg"
3. Close FF
4. Check Processes tab

Actual:
Firefox hangs and additional tabs cannot go to any website.
Closing Firefox will close the browser but there is an instance of firefox.exe still running in processes.

Expected:
Should handle reserved filenames gracefully.
Does not happen on IE7.
Actual Results:  
Actual:
Firefox hangs and additional tabs cannot go to any website.
Closing Firefox will close the browser but there is an instance of firefox.exe still running in processes.


Expected Results:  
Expected:
Should handle reserved filenames gracefully.
Does not happen on IE7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 29079
You need to log in before you can comment on or make changes to this bug.