Live feeds display article dates instead of titles (in debug build only)

RESOLVED FIXED

Status

()

RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: kherron+mozilla, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
With recent trunk builds of firefox, all of my live feeds display article dates instead of article titles. When I click on a live feed bookmark to display an article list, the list is just a series of dates with no article titles.

I subscribe to about 25 live feeds in all, including slashdot's main feed (see the sample URL) and planet mozilla. I have a FF build from July 8, 2007 which works correctly; live feeds display article titles. When I shut down this build of FF and start a newer one (e.g. from July 28) my live feeds initially display article titles, but after a couple of minutes--presumably after the feed is reloaded--the article list switches to showing dates. When I switch back to my July 8 build, it displays article dates until the feeds are reloaded, then switches back to titles.

I also produced this with a new profile. Using the July 28 build, I created a new profile and waited for the "latest headlines" live feed to load. All entries in the menu were dates instead of titles. 

My July 28 build is a debug build, and it prints many copies of the following message which may be relevant:

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "'[JavaScript Error: "stateTuple has no properties" {file: "file:///extra/kherron/moz3/ff/dist/bin/components/FeedProcessor.js" line: 1596}]' when calling method: [nsISAXContentHandler::endElement]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///extra/kherron/moz3/ff/dist/bin/components/FeedProcessor.js :: FP_onDataAvailable :: line 1320"  data: yes]
************************************************************
Works for me in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/200708020808 Minefield/3.0a7pre.

Can you reproduce the problem with the current trunk build? I have used a bunch of live feeds in testing today and seen no issues.
(Reporter)

Comment 2

11 years ago
I tried downloading nightlies from ftp.mozilla.org. Those builds work properly. I built a fresh copy of FF using the same codebase as one of my non-working builds with mozconfig options taken from a nightly build. That copy works correctly as well.

It may be specific to my build options; these are from the working build:

    . $topsrcdir/browser/config/mozconfig

    ac_add_options --enable-update-channel=nightly
    ac_add_options --enable-update-packaging
    ac_add_options --enable-optimize='-Os -freorder-blocks
                                      -fno-reorder-functions -gstabs+'
    ac_add_options --disable-debug
    ac_add_options --disable-tests
    ac_add_options --enable-codesighs

And these are from the non-working build:

    . $topsrcdir/browser/config/mozconfig

    ac_add_options --enable-crypto
    ac_add_options --enable-debug
    ac_add_options --enable-default-toolkit=cairo-gtk2
    ac_add_options --enable-optimize='-Os -march=athlon-xp -mfpmath=sse
                                      -momit-leaf-frame-pointer'

I don't think the "xpconnect wrapped JSObject" error is relevant; I don't see it with either build when I force the live bookmark to reload.
I use the nightlies every day (as does the entire QA team). What do you mean that "those builds don't work properly"? Can you tell me what issues you are seeing with them?
(Reporter)

Comment 4

11 years ago
I think you misread my post. I said "Those builds work properly", meaning the nightly builds that I downloaded all worked properly.
(Reporter)

Comment 5

11 years ago
I took the mozconfig that produces a working build (from comment 2), changed --disable-debug to --enable-debug, and did a clobber build. The new build displays the same problem: live bookmarks show a date for each article instead of a title. So maybe the problem is specific to debug builds.
Component: Bookmarks → RSS Discovery and Preview
QA Contact: bookmarks → rss.preview
Component: RSS Discovery and Preview → Places
QA Contact: rss.preview → places
(Reporter)

Comment 6

11 years ago
Through binary search, I've narrowed it down to the checkin to mozilla/js/src/xpconnect/src/xpcvariant.cpp at 2007-07-20 18:03 for bug 384632. Builds before this time work correctly; newer builds display the problem.
Blocks: 384632
Keywords: regression
(Reporter)

Comment 7

11 years ago
fieldsToObj() in FeedProcessor.js is failing to retrieve most of the XML properties that it looks for. I added some dump() calls to fieldsToObj() and got this parsing slashdot's main feed:

*** fieldstoobj: title not found
*** fieldstoobj: rss1:title not found
*** fieldstoobj: atom03:title not found
*** fieldstoobj: atom:title not found
*** fieldstoobj: link not found
*** fieldstoobj: rss1:link: http://rss.slashdot.org/~r/Slashdot/slashdot/~3/153789491/article.pl
*** fieldstoobj: guid not found
*** fieldstoobj: rdf:about: http://yro.slashdot.org/article.pl?sid=07/09/08/0318208&from=rss
*** fieldstoobj: atom03:id not found
*** fieldstoobj: atom:id not found
*** fieldstoobj: authors: [xpconnect wrapped (nsISupports, nsIMutableArray, nsIArray) @ 0x974bd08 (native @ 0x97caaf0)]
*** fieldstoobj: contributors not found
*** fieldstoobj: description not found
*** fieldstoobj: rss1:description not found
*** fieldstoobj: dc:description not found
*** fieldstoobj: atom03:summary not found
*** fieldstoobj: atom:summary not found
*** fieldstoobj: content:encoded not found
*** fieldstoobj: atom03:content not found
*** fieldstoobj: atom:content not found
*** fieldstoobj: atom03:rights not found
*** fieldstoobj: atom:rights not found
*** fieldstoobj: atom03:issued not found
*** fieldstoobj: dcterms:issued not found
*** fieldstoobj: atom:published not found
*** fieldstoobj: pubDate not found
*** fieldstoobj: atom03:modified not found
*** fieldstoobj: dc:date: 2007-09-08T08:29:00+00:00
*** fieldstoobj: dcterms:modified not found
*** fieldstoobj: atom:updated not found
Summary: Live feeds display article dates instead of titles → Live feeds display article dates instead of titles (in debug build only)
Are we sure this is the only thing that bug 384632 broke? mrbkap, any ideas here? Anything to be looking for in particular?
Flags: blocking-firefox3?
This does not block the final release of Firefox 3.
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
I wonder if the patch in bug 415037 fixes this.
(Reporter)

Comment 11

11 years ago
I was able to reproduce this bug last weekend. But I just updated my tree and rebuilt, and I can't reproduce it any longer. I'm going to mark this one as fixed by the patch for bug 415037 per comment 10.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Depends on: 415037
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.