All users were logged out of Bugzilla on October 13th, 2018

Non-responsive script error

RESOLVED FIXED

Status

--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: jmjeffery, Assigned: rginda)

Tracking

({regression})

Trunk
x86
Windows Vista
regression

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007080206 Minefield/3.0a7pre Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007080206 Minefield/3.0a7pre Firefox/3.0 ID:2007080206

Opening Chatzilla results in application going not responding, and eventually a warning box about a script taking too long, stop script or continue.  After clicking 'stop' a 'Client' tab is opened that is blank, and when joining #firefox IRC channel it shows 'channel view opened', but no users, no mode is shown, and the window remains 'blank'. 

Reproducible: Always

Steps to Reproduce:
1.  Use a trunk build with a date of 0802 or later 
2.  Open Chatzilla, note it goes not responding, slow script warning box.
3.


Expected Results:  
Chatzilla should open.

Vista Home Premium
(Reporter)

Updated

11 years ago
Keywords: regression
Version: unspecified → Trunk

Comment 2

11 years ago
Works for me on XP.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007080207 Minefield/3.0a7pre
Anyone who can reproduce, please run under a debugger and break as often as you can, recording stack backtraces and attaching them. Look for a common prefix among the stacks, which might end in the frame that's looping (if there's an iloop).

/be
FWIW http://tweakers.net/ causes the Unresponsive Script dialog too.
Works: 20070801_1805_firefox-3.0a7pre.en-US.win32.zip (pre bug 385393)
Problem: 20070801_2140_firefox-3.0a7pre.en-US.win32.zip (post bug 385393)
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1186016700&maxdate=1186029599
Please try the patch for bug 390684 if you can.

/be
I just downloaded the latest hourly: 
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a7pre) Gecko/2007080212 Minefield/3.0a7pre Firefox/3.0 ID:2007080212

And Chatzilla is working again, no errors.  Thanks for the quick fix.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.