Gecko not Rendering GMail Site to MSAA

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: tkeenan, Assigned: aaronlev)

Tracking

({access, sec508})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007080204 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a7pre) Gecko/2007080204 Minefield/3.0a7pre

I receive nothing in Jaws and the following in Window-eyes:
wyciwyg://0/http://mail.google.com/mail/?view=page&name=js&ver=1t6ksswaq6lz2



Reproducible: Always

Steps to Reproduce:
1. Open www.gmail.com
2. Sign in.

3.
Actual Results:  
Buffer is empty or contains one line.

Expected Results:  
Should at least see the html elements of the page.
(Assignee)

Comment 1

11 years ago
Any idea when this regressed?
(Assignee)

Updated

11 years ago
Assignee: nobody → aaronleventhal
Component: Disability Access → Disability Access APIs
Product: Firefox → Core
QA Contact: disability.access → accessibility-apis
(Assignee)

Comment 2

11 years ago
It might be one of those internal crashes that MSAA so inconveniently swallows.

I wonder if it works with Orca.
This sounds like it might be caused by bug 255820, given the wyciwyg changes it made and the URL you`re seeing in Window-eyes (see also bug 390168).
(Assignee)

Comment 4

11 years ago
Tim, you could check if it breaks that day.
(Reporter)

Comment 5

11 years ago
Aaron, I'm not sure what you mean.
Also, the site:
http://citeseer.ist.psu.edu/464827.html

has the same problem, except this time nothing is spoken in Window-eyes or Jaws.  Note that you are able to review the site with the mouse cursor of each screen-reader, but it's not loading into the buffer.


(Assignee)

Updated

11 years ago
Severity: normal → major
Flags: blocking1.9?
Keywords: access, sec508
(Assignee)

Comment 6

11 years ago
Tim, that's useful to have 2 examples.

What I was asking if you could figure out what day it broke. That'd be super helpful.
(Assignee)

Comment 7

11 years ago
I have the info:
2007-07-05 works
2007-07-06 broken
(Assignee)

Comment 8

11 years ago
I believe this was caused by bug 377783.

It works now. I think Ginn's fix in bug 387347 fixed it. He made my empty frame check so it only occurs on table caption frames, which is much last drastic.

Tim, please verify that it works again in nightly builds for you.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

11 years ago
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.