Closed Bug 390891 Opened 13 years ago Closed 13 years ago

Embedded WMV content does not display

Categories

(Core :: Plug-ins, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: u279076, Unassigned)

References

()

Details

Going to the provided URL, the embedded video doesnt play.  The only way I can get
it to play is by going to View Page Info, extracting the URL of the video
content and playing the video in WMP.

This was tested on GPa7rc1 build ID 2007080210 on WinXP

The URL was provided in a litmus test case.

Steps to reproduce:
1. Navigate to the provided URL

Actual Results:
Video control does not display.

Expected results:
Video control should display and allow the user to play the embedded video.

Reproducible:
Always
http://members.aol.com/jrzycrim01/mozilla/wmp/vidtest-HS.html
seems to contain a video with the <object> element and the source of the video
is http://members.aol.com/jrzycrim01/mozilla/wmp/vidtest-HS.wmv
That seems to be sent as mime-type text/plain.
It seems to be a problem similar to bug 389677. Not sure if I agree with the
conclusion of that bug, though.
IE displays the video just fine, Mozilla used to display the video just fine, why shouldn't Mozilla continue to do that?
Blocks: 1156
(In reply to comment #1)
> why shouldn't Mozilla continue to do that?

Because it was a bug that we did show it...

I'm afraid this will just hurt Mozilla.
Most people don't understand why something is working in IE and not in Mozilla anyway. And now changing something from working to non-working, makes it even worse.

I know that stylesheets still work, when they are being sent with the wrong mime-type. This is for compatibility reasons. 
In my opinion, that should also be happening here.
Depends on: 389677
bug 389677 should fix this for most cases
The video in the given URL WFM.  
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050506 Minefield/3.0pre ID:2008050506
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9pre) Gecko/2008050606 Minefield/3.0pre

The URL works great.  Resolving WORKSFORME.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.