The default bug view has changed. See this FAQ.

Zoom UI extensions affect whole chrome when no page is loaded

RESOLVED WORKSFORME

Status

Core Graveyard
GFX
RESOLVED WORKSFORME
10 years ago
8 years ago

People

(Reporter: Daniel Luz, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080405 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080405 Minefield/3.0a8pre

When there's no document open (i.e. a new tab opens and the page is still
loading, not when you are looking at about:blank) the zoom is applied to the
whole chrome.

Reproducible: Always

Steps to Reproduce:
1. Open and focus a new tab with some address that takes a while to load
2. Before the page starts rendering, use any zoom extension, OR open the
   error console and type:
   top.opener.getBrowser().mCurrentBrowser.markupDocumentViewer.fullZoom = 1.2
Actual Results:  
Menu bar, toolbars, tab bar and status bar get scaled up/down.

Expected Results:  
Either nothing should happen, or the document should zoom once it loaded.
(Reporter)

Updated

10 years ago
Blocks: 4821
Version: unspecified → Trunk

Comment 1

10 years ago
works for me using attachment 274906 [details].

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080405 Minefield/3.0a8pre
(Reporter)

Comment 2

10 years ago
I just tried to reproduce it, and succeeded, using both Full Page Zoom (the toolbar buttons) and Zoom In (the statusbar drop-down). Then wondering if it could be because of some of my other (few) extensions, I disabled them all and started trying to reproduce the bug.

So far I haven't been able to reproduce it anymore, even with the same setup I had before. I'm marking it WFM until I can find more reliable reproduction steps.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

8 years ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.