The default bug view has changed. See this FAQ.

Remove scary message about multiple SMTP servers from Account Settings

RESOLVED FIXED in Thunderbird 15.0

Status

MailNews Core
Account Manager
--
enhancement
RESOLVED FIXED
10 years ago
5 years ago

People

(Reporter: Rod Whiteley, Assigned: aceman)

Tracking

({polish, uiwanted, ux-tone})

Trunk
Thunderbird 15.0
polish, uiwanted, ux-tone
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

8.41 KB, patch
aceman
: review+
Details | Diff | Splinter Review
(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070728 Thunderbird/2.0.0.6

In Account Settings, the Outgoing Server (SMTP) Settings page says:

"Although you can specify more than one outgoing server (SMTP), this is only recommended for advanced users. Setting up multiple SMTP servers can cause errors when sending messages."

This is misleading. Anyone who is capable of setting up an account is capable of setting up and using additional SMTP servers, and this does not (and never did) in itself cause errors when sending messages.

Reproducible: Always




Related to bug 222388 and see also: http://kb.mozillazine.org/Multiple_SMTP_servers_-_Thunderbird

Proposed new wording:

"To use a server in this list, specify it as the Outgoing Server (SMTP) for one or more of your identities. To use the Default server in this list, specify 'Use Default Server' as the Outgoing Server (SMTP) for one or more of your identities."
FYI.
Following great page was created recently, and "SMTP servers" section explains Mozilla family's SMTP configuration related concept very well.    
  http://kb.mozillazine.org/Mail_concepts
I hope this excellent concept is notified to users via simple explanation in panels or messages, because Thunderbird still doesn't have great Help/Help contents feature of Mozilla/Seamonkey.
(Assignee)

Comment 2

5 years ago
This would be easy to do, it just needs decision from the UI guys.
Assignee: nobody → acelists
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: uiwanted, ux-tone
OS: Windows XP → All
Hardware: x86 → All
Version: unspecified → Trunk
(Assignee)

Updated

5 years ago
Component: Account Manager → Account Manager
Product: Thunderbird → MailNews Core
QA Contact: account-manager → account-manager
(Assignee)

Comment 3

5 years ago
Created attachment 598288 [details] [diff] [review]
patch, change string
Attachment #598288 - Flags: ui-review?(bwinton)
Attachment #598288 - Flags: review?(iann_bugzilla)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Keywords: polish

Comment 4

5 years ago
Comment on attachment 598288 [details] [diff] [review]
patch, change string

>+<!ENTITY smtpDescription.label "To use a server in this list, specify it as the Outgoing Server (SMTP) for one or more of your identities. To use the Default server in this list, specify 'Use Default Server' as the Outgoing Server (SMTP) for one or more of your identities.">
Would it be better to say "select" rather than "specify"?
Would a better way of indicating where this action is done be saying something like "When managing your identities you can use a server from this list by selecting it as the Outgoing Server (SMTP). etc"?

r=me with those questions answered/addressed
Attachment #598288 - Flags: review?(iann_bugzilla) → review+
Comment on attachment 598288 [details] [diff] [review]
patch, change string

The /mail/ parts look good.  ui-r=me.  (I don't know if you also need a ui-r for the /suite/ parts, though…)

Thanks,
Blake.
Attachment #598288 - Flags: ui-review?(bwinton) → ui-review+
(Assignee)

Comment 6

5 years ago
I thought Ian's review is enough for SM strings.
Bwinton, can you also answer Ian's questions? I am not actually sure what the resulting string should be.
(Assignee)

Comment 7

5 years ago
Comment on attachment 598288 [details] [diff] [review]
patch, change string

Bwinton, please see the comments.
Attachment #598288 - Flags: feedback?(bwinton)
Comment on attachment 598288 [details] [diff] [review]
patch, change string

Yeah, I like "select" better than "specify", since you are selecting an item from a list, not typing in the settings…

> Would a better way of indicating where this action is done be saying something
> like "When managing your identities you can use a server from this list by
> selecting it as the Outgoing Server (SMTP). etc"?

Perhaps.  I'm not sure about the benefits of putting the location first, as opposed to putting the proposed action first.

The final string would be 'When managing your identities you can use a server from this list by selecting it as the Outgoing Server (SMTP), or you can use the default server from this list by selecting "Use Default Server".'

(Please use "s around "Use Default Server" the string.)

That seems shorter, and still reasonably clear.  Ian?  Do you still like the new wording?
Attachment #598288 - Flags: feedback?(bwinton) → feedback+
(Assignee)

Comment 9

5 years ago
Created attachment 614901 [details] [diff] [review]
patch v2
Attachment #598288 - Attachment is obsolete: true
Attachment #614901 - Flags: ui-review?(bwinton)
Attachment #614901 - Flags: review?(iann_bugzilla)
Comment on attachment 614901 [details] [diff] [review]
patch v2

Looks good to me!  ui-r+!

Thanks,
Blake.
Attachment #614901 - Flags: ui-review?(bwinton) → ui-review+

Updated

5 years ago
Attachment #614901 - Flags: review?(iann_bugzilla) → review+
(Assignee)

Updated

5 years ago
Attachment #614901 - Flags: review?(mconley)
Comment on attachment 614901 [details] [diff] [review]
patch v2

Review of attachment 614901 [details] [diff] [review]:
-----------------------------------------------------------------

aceman:

Just two nits, r=me with those fixed.

Also, I really like how you're cleaning up the code while you're fixing this stuff.  Thumbs up.

-Mike

::: mail/locales/en-US/chrome/messenger/am-advanced.dtd
@@ +2,5 @@
>  
>  <!-- LOCALIZATION NOTE (smtpServer.label): do not translate "SMTP" in below line -->
>  <!ENTITY smtpServer.label "Outgoing Server (SMTP) Settings">
>  
>  <!-- LOCALIZATION NOTE (smtpDesc.label): do not translate "SMTP" in below line -->

This comment needs to be updated to match the new string key.

::: suite/locales/en-US/chrome/mailnews/pref/am-advanced.dtd
@@ +1,3 @@
>  <!-- LOCALIZATION NOTE (smtpServer.label): do not translate "SMTP" in below line -->
>  <!ENTITY smtpServer.label "Outgoing Server (SMTP) Settings">
>  <!-- LOCALIZATION NOTE (smtpDesc.label): do not translate "SMTP" in below line -->

Same as before - this comment needs updating to match the string key.
Attachment #614901 - Flags: review?(mconley) → review+
(Assignee)

Comment 12

5 years ago
Created attachment 618035 [details] [diff] [review]
patch v3

When do I stop forgetting these rules...
Attachment #614901 - Attachment is obsolete: true
Attachment #618035 - Flags: review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
http://hg.mozilla.org/comm-central/rev/3fb688e2aef2
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite-
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 15.0
You need to log in before you can comment on or make changes to this bug.