Closed Bug 391063 Opened 13 years ago Closed 11 years ago

Add TODO/Task support via Google Documents API

Categories

(Calendar :: Provider: GData, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 493389

People

(Reporter: Fallen, Unassigned)

References

()

Details

Google Calendar doesn't support any form of todo lists. There are several ways that this could be worked around:

* Use the Google Documents API (see url) to create an ICS file with TODO events
* Use the Google Documents API (see url) to create a custom XML list of todo events
* Create a separate Calendar with a similar name that saves todo items as zero-length or allday events.

Regardless of the method chosen, the todo items will not nativly be shown on the source calendar, but since the data is stored at google, it will be accessible from any location.

I favor using the documents api. Comments welcome!
I would prefer the first option (Google Documents API + ICS file) as it allows direct use without any conversion by any program that is able to retrieve data via GD-API. But I have no idea it it ever happens so if this is important.
Duplicate of this bug: 402984
Duplicate of this bug: 402984
Duplicate of this bug: 410795
Duplicate of this bug: 434890
Duplicate of this bug: 435841
Duplicate of this bug: 391245
Duplicate of this bug: 387388
Duplicate of this bug: 434890
Duplicate of this bug: 386230
Duplicate of this bug: 453356
According to the official gMail blog, GMail now supports Tasks.
http://gmailblog.blogspot.com/2008/12/new-in-labs-tasks.html

So there will be no need to add this via google docs.
(In reply to comment #12)
GMail is not the same as Google Calendar.
(In reply to comment #13)

True, but the same is true for Google Docs - they're not strictly the same thing as GCal.

My $0.02 is that I don't really care where the functionality comes from, as long as it's supported somehow, if I'm only going to look at it from Thunderbird. BTW, it's quite likely that I'd be using GMail anyway (especially since they started supporting IMAP), through the account that I can easily obtain with the same credentials as GCal.
Right now this is a Google Labs only feature and it has no API yet. I'm sure I could hack into it and try to emulate the calls they do, but thats probably more work than its worth.

We'll have to wait until Google officially introduces an API for the tasks feature, sorry.
(In reply to comment #15)
> We'll have to wait until Google officially introduces an API for the tasks
> feature, sorry.

Fair enough :-)
Google now has native tasks, but no API yet. See bug 493389.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: gdata-tasks
You need to log in before you can comment on or make changes to this bug.