If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash on accessing about:license

RESOLVED FIXED

Status

()

Core
Layout: Text
--
critical
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: V. Korn, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080605 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080605 Minefield/3.0a8pre

Crashing if i try to view about:license page

Reproducible: Always

Steps to Reproduce:
1.type about:license in urlbar
2.press enter
3.
Actual Results:  
Crash

Expected Results:  
view license information
Points to the back-out of Bug 385270 = Bug 386584.
i don`t crash with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/200708060505 Minefield/3.0a8pre on about:license

Only when i change the font size (Bug 386584). 

Reporter: do you crash when anytime when you open about:license or when you change the font size.

If you crash anytime without changing the frontsize, can you add a crashreport to this bug, see http://kb.mozillazine.org/Breakpad#Location_of_crash_reports
Severity: normal → critical
Keywords: crash
Version: unspecified → Trunk
(Reporter)

Comment 3

10 years ago
Sorry, i spent some time to recheck my report and should now correct it.
To reproduce crash your need:
1)Open Firefox
2)type about: in urlbar, press enter, wait to load page
3) Find "See the build configuration used for this version." string and open link  "build configuration" in NEW tab (use context menu)
4) After it, click on "licensing information" link and get actual crash.

About breakpads - after crash Breakpad shows up, but send nothing, sorry
(Reporter)

Comment 4

10 years ago
Ooops, not all crash reports trashed - 
http://crash-stats.mozilla.com/report/index/e9702d51-4474-11dc-8647-001a4bd43e5c?date=2007-08-06-23
http://crash-stats.mozilla.com/report/index/096626f0-4475-11dc-a30b-001a4bd43e5c?date=2007-08-06-23

Maybe it helps...

Comment 5

10 years ago
Firefox 3.0a8pre Crash Report
UUID	e9702d51-4474-11dc-8647-001a4bd43e5c
Time	2007-08-06 16:29:43.760000-07:00
Build ID	2007080605
OS	Windows NT
OS Version	5.1.2600 Service Pack 2
CPU	x86
CPU Info	GenuineIntel family 15 model 2 stepping 7
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x63caf828
URL	about:
Stack Traces
Stack of Crashing Thread
frame 	signature 	source
0 	gfxSkipCharsIterator::SetOffsets(unsigned int, int) 	e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\gfx\thebes\src\gfxskipchars.cpp:129
1 	BuildTextRunsScanner::SetupBreakSinksForTextRun(gfxTextRun*, int, int) 	e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\layout\generic\nstextframethebes.cpp:1892
2 	BuildTextRunsScanner::BuildTextRunForFrames(void*) 	e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\layout\generic\nstextframethebes.cpp:1787
3 	BuildTextRunsScanner::FlushFrames(int) 	e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\layout\generic\nstextframethebes.cpp:1253
4 	BuildTextRuns 	e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\layout\generic\nstextframethebes.cpp:1212
5 	nsTextFrame::EnsureTextRun(nsIRenderingContext*, nsIFrame*, nsLineList_iterator const*, unsigned int*) 	e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\layout\generic\nstextframethebes.cpp:1969
6 	nsTextFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned int&) 	e:\builds\tinderbox\fx-trunk\winnt_5.2_depend\mozilla\layout\generic\nstextframethebes.cpp:5285
Component: General → Layout: Fonts and Text
Depends on: 385270
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
About:license crashes here too reliably, only you need to reload sometimes.

Comment 7

10 years ago
Following the steps in comment 3, I am unable to reproduce this on Windows Vista with a clean profile and the latest nightly.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a9pre) Gecko/2007101005 Minefield/3.0a9pre ID:2007101005
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081205 Minefield/3.0a8pre

crash going to about:license

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007082005 Minefield/3.0a8pre

no crash going to about:license or following steps in comment 3

Presumably fixed by bug 385270, resolving FIXED in keeping with the trend of other deps of bug 385270
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.