Firefox -app trick to run XULRunner app loads http://www.mozilla.com/projects/myapp/1.0/firstrun/

RESOLVED FIXED in mozilla1.9alpha8

Status

Toolkit Graveyard
XULRunner
--
minor
RESOLVED FIXED
10 years ago
2 years ago

People

(Reporter: skierpage, Assigned: mfinkle)

Tracking

unspecified
mozilla1.9alpha8
x86
Windows XP

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080605 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080605 Minefield/3.0a8pre ID:2007080605

I read about bug 388833, and tried it with the minimal myapp sample from http://developer.mozilla.org/en/docs/Getting_started_with_XULRunner

It worked (wahoo!), but it also opened a browser window to http://www.mozilla.com/projects/myapp/1.0/firstrun/ , obviously a 404.

Reproducible: Didn't try

Steps to Reproduce:
1. Download http://developer.mozilla.org/samples/xulrunner/myapp.zip
2. Fix its application.ini for Minefield's Gecko 1.9 (see bug 389113).
3. Use -app trick to start app, e.g.
   > cd "C:\Program Files\Minefield"
   > firefox -app "\full\path\to\myapp\application.ini"
Actual Results:  
The little My App XULRunner app appears (good!)
But also a new browser window appears that opens http://www.mozilla.com/projects/myapp/1.0/firstrun/  (I think that was the URL, Minefield crashed while I was entering this bug ;-) .)
obviously this is a 404.

I believe this browser window is in a separate process from my running Minefield, because it lacked my add-ons and bookmarks.

I started the XULRunner app a second time, and a blank browser window appeared.

Expected Results:  
I'm not sure!  There's nothing in myapp's application.ini about www.mozilla.com/projects or firstrun.

(My motivation is to make it easier to see if bugs are specific to Firefox 3 or in its underlying toolkit.  However, that would require a more substantial XULRunner app.)

Comment 1

10 years ago
This is the problem noted in bug 388833 comment 1. The firefox components (the commandline handlers in particular) are in effect.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

10 years ago
Assignee: nobody → mark.finkle
Target Milestone: --- → mozilla1.9 M8
(Assignee)

Comment 2

10 years ago
Created attachment 276900 [details] [diff] [review]
add a check to skip firefox commandline handler when launching xr app

This patch keeps the default commandline handlers from registering/running when Firefox is launching a xulrunner application
Attachment #276900 - Flags: review?(gavin.sharp)

Comment 3

10 years ago
Comment on attachment 276900 [details] [diff] [review]
add a check to skip firefox commandline handler when launching xr app

-    var compReg =
+   var compReg =

You've lost one character of indentation on this line. :)
(Assignee)

Comment 4

10 years ago
Created attachment 276916 [details] [diff] [review]
v2

same as the first patch with indent fixup
Attachment #276900 - Attachment is obsolete: true
Attachment #276916 - Flags: review?(gavin.sharp)
Attachment #276900 - Flags: review?(gavin.sharp)
Attachment #276916 - Flags: review?(gavin.sharp) → review+
(Assignee)

Comment 5

10 years ago
new revision: 1.44; previous revision: 1.43
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Depends on: 394990
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.