Closed Bug 391270 Opened 13 years ago Closed 13 years ago

setInterval being fired like crazy on wake up after sleep or hibernate

Categories

(Core :: DOM: Events, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 376643

People

(Reporter: tpierron, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6


Wonder If anymore out there notice that behavior :

- Have a page doing request on periodic interval (using XMLHttpRequest for example).
- Put your computer to sleep
- Wake up your computer some time later (usually several hours later).
- All request that should be sent between while the computer was sleeping, are sent on wake up : this cause a massive memory leak, and browser becoming sluggish even after reloading page to force garbage collection.


For example, I got one of my (private) site that checks updates every 5 seconds. The evening, when I left the office around 6pm, I put my computer to sleep. I wake it up the morning around 9am. That is roughly 14 hours. During that time, more than 10000 requests should have been sent. When I look in ProcessExplorer, I see the memory constantly increasing (usually memory is around 60M, after such event it grows up to 200M). If I reload the page, it never goes down. Moreover, browser starts to become sluggish, freezing a few tenth of seconds every 5 seconds or so.

My first thought was missing requests are issued on wake up. So I set up a simple CGI that simply counts how many time it has been called (or hit). On client side I setup a page which issue a request on the CGI using XMLHttpRequest, I also track how many requests have been created and how many responses I receive.

I notice that number of response continue where it stops, but number of request and number of hit continue where it would have been if computer wasn't put to sleep, issuing lots or request on wake up.


Reproducible: Always
This is a page that perform a CGI request to /cgi-bin/count.exe. It expect to receive a number that increase each time the cgi is called. You might have to adapt it a bit to see it working : especially the server part, I think it is pointless to give you a script/exe that does this job.
I think I see this with my MacBook when I wake it up, thanks to Tinderstatus.
This was fixed in GranParadiso Alpha 7 (will become Firefox 3.0) : see bug 376643. It's not yet sure if it will be fixed in Firefox 2.0.0.*
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376643
You need to log in before you can comment on or make changes to this bug.