Last Comment Bug 391412 - Regression in float layout causing "clear:" to be ignored
: Regression in float layout causing "clear:" to be ignored
Status: VERIFIED FIXED
: regression, verified1.8.1.10, verified1.8.1.9
Product: Core
Classification: Components
Component: Layout: Floats (show other bugs)
: Trunk
: All All
: -- major (vote)
: ---
Assigned To: Eli Friedman
:
:
Mentors:
http://alistapart.com/d/multicolumnla...
Depends on:
Blocks: 387201 400406
  Show dependency treegraph
 
Reported: 2007-08-08 11:55 PDT by Jake
Modified: 2007-11-15 07:57 PST (History)
13 users (show)
dbaron: blocking1.9?
mtschrep: blocking1.8.1.9+
dveditz: blocking1.8.1.10+
martijn.martijn: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.68 KB, patch)
2007-08-08 17:45 PDT, Eli Friedman
roc: review+
roc: superreview+
dveditz: approval1.8.1.9+
dveditz: approval1.8.1.10+
dbaron: approval1.9+
Details | Diff | Splinter Review
reftest (2.80 KB, patch)
2007-10-22 07:32 PDT, Martijn Wargers [:mwargers] (not working for Mozilla)
bzbarsky: review+
Details | Diff | Splinter Review

Description Jake 2007-08-08 11:55:30 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/2007072604 Minefield/3.0a7pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a7pre) Gecko/2007072604 Minefield/3.0a7pre

This behaviour was introduced with Gecko/2007072604 Minefield/3.0a7pre and persists up until latest nightly (Gecko/2007080804). It causes a "cleared" box to not remain beneath "floated" boxes.

Reproducible: Always

Steps to Reproduce:
1. Install Firefox3.0 from 20070726 onward
2. Open specified webpage in nightly and in latest 2.0 release
3. Compare
Actual Results:  
The "footer" refuses to remain beneath the leftRail, center, rightRail elements allthough it has been set to "clear:all". Also, the background of said elements disappears.

Expected Results:  
Firefox 2.0 and 3.0 up until 20070725 render the page correctly.

Giving the "floated" boxes a "border" will resolve the incorrect beaviour.
Comment 1 Adam Guthrie 2007-08-08 15:27:09 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007080805 Minefield/3.0a8pre

I narrowed down the regression range a bit more. It regressed sometime between 2007-07-26-05 and 2007-07-26-15. The patches for bug 387201 and bug 386640 are the ones that jump out at me, both of which are Eli's.
Comment 2 Eli Friedman 2007-08-08 17:45:15 PDT
Created attachment 275902 [details] [diff] [review]
Patch
Comment 3 Eli Friedman 2007-08-08 17:45:39 PDT
Regression from bug 387201.
Comment 4 David Baron :dbaron: ⌚️UTC-7 (busy September 14-25) 2007-08-19 15:07:10 PDT
Comment on attachment 275902 [details] [diff] [review]
Patch

a1.9=dbaron
Comment 5 Eli Friedman 2007-08-20 14:06:17 PDT
Checked in.
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2007-10-19 21:30:22 PDT
Comment on attachment 275902 [details] [diff] [review]
Patch

Yikes.  We shipped the bug this is a regression from on branch... but didn't put this fix on branch.
Comment 7 Boris Zbarsky [:bz] (still a bit busy) 2007-10-19 21:40:55 PDT
Can someone create a reftest here?  We should be making sure not to regress this again, ever.
Comment 8 Carsten Book [:Tomcat] 2007-10-21 16:12:08 PDT
verified fixed for trunk on:

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a9pre) Gecko/2007102005 Minefield/3.0a9pre ID:2007102005

Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a9pre)
Gecko/2007102104 Minefield/3.0a9pre

and Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a9pre) Gecko/2007102104
Minefield/3.0a9pre (Linux Fedora F7)

with the example url from this bug. -> Verified
Comment 9 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-10-22 07:32:11 PDT
Created attachment 285729 [details] [diff] [review]
reftest
Comment 10 Carsten Book [:Tomcat] 2007-10-22 10:45:32 PDT
*** Bug 400709 has been marked as a duplicate of this bug. ***
Comment 11 Boris Zbarsky [:bz] (still a bit busy) 2007-10-22 12:02:34 PDT
Comment on attachment 285729 [details] [diff] [review]
reftest

r=bzbarsky assuming this passes in Gecko 1.8.1.7 and fails in Gecko 1.8.1.8.
Comment 12 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-10-22 14:57:28 PDT
Comment on attachment 285729 [details] [diff] [review]
reftest

(In reply to comment #11)
> (From update of attachment 285729 [details] [diff] [review])
> r=bzbarsky assuming this passes in Gecko 1.8.1.7 and fails in Gecko 1.8.1.8.

Yes, it does.

Asking approval1.9? because I don't know how check-in rules are regarding reftests.
Comment 13 Reed Loden [:reed] (use needinfo?) 2007-10-22 14:59:58 PDT
Comment on attachment 285729 [details] [diff] [review]
reftest

Tests have implicit approval to land as long as the tree is open, so land away!
Comment 14 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-10-22 15:34:31 PDT
Ok, thanks for the info, reftest checked in.
Comment 15 Daniel Veditz [:dveditz] 2007-10-22 15:35:17 PDT
Comment on attachment 275902 [details] [diff] [review]
Patch

approved for 1.8.1.9 and 1.8.1.10, a=dveditz for release-drivers.

For 1.8.1.9 please check in to GECKO181_20071004_RELBRANCH. For 1.8.1.10 check into the normal MOZILLA_1_8_BRANCH
Comment 16 Reed Loden [:reed] (use needinfo?) 2007-10-22 15:48:26 PDT
GECKO181_20071004_RELBRANCH:

Checking in layout/generic/nsSpaceManager.cpp;
/cvsroot/mozilla/layout/generic/nsSpaceManager.cpp,v  <--  nsSpaceManager.cpp
new revision: 3.65.6.2.2.1; previous revision: 3.65.6.2
done

MOZILLA_1_8_BRANCH:

Checking in layout/generic/nsSpaceManager.cpp;
/cvsroot/mozilla/layout/generic/nsSpaceManager.cpp,v  <--  nsSpaceManager.cpp
new revision: 3.65.6.3; previous revision: 3.65.6.2
done
Comment 17 Carsten Book [:Tomcat] 2007-10-23 08:57:09 PDT
verified fixed using :

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8pre) Gecko/2007102303 BonEcho/2.0.0.8pre and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.8pre) Gecko/2007102303 BonEcho/2.0.0.8pre and the testurl from this bug. 

With the current 1.8 Nightly Builds the Layout is not broken. 
Comment 18 Carsten Book [:Tomcat] 2007-10-23 11:51:11 PDT
(In reply to comment #17)
> verified fixed using :
> 
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.8pre) Gecko/2007102303
> BonEcho/2.0.0.8pre and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.8.1.8pre) Gecko/2007102303 BonEcho/2.0.0.8pre and the testurl from this
> bug. 
> 
> With the current 1.8 Nightly Builds the Layout is not broken. 
> 

also verified fixed 1.8.1.9 in Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.8pre) Gecko/2007102306 BonEcho/2.0.0.8pre

-> adding verified keyword
Comment 19 Carsten Book [:Tomcat] 2007-11-15 07:57:04 PST
verified fixed 1.8.1.10 using Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.10pre) Gecko/2007111503 BonEcho/2.0.0.10pre

- Adding verified keyword

Note You need to log in before you can comment on or make changes to this bug.