Closed Bug 391496 Opened 13 years ago Closed 12 years ago

Create "staging" mac buildbot slave for Mozilla1.8 / FF2.0.0.x

Categories

(Release Engineering :: General, defect, P2)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: joduinn, Assigned: joduinn)

References

Details

We need a mac buildbot slave running on hardware/toolset that matches our current Mozilla1.8 / FF2.0.0.x environment on bm-xserve02.build.mozilla.org

bm-xserve02$ uname -a
Darwin bm-xserve02.mozilla.org 8.7.0 Darwin Kernel Version 8.7.0: Fri May 26 15:20:53 PDT 2006; root:xnu-792.6.76.obj~1/RELEASE_PPC Power Macintosh powerpc
bm-xserve02$ 


We are still trying to clarify exact inventory, but one suggestion is bm-xserve01.build.mozilla.org. Its being used (only lightly) by dmills repack tools. While bm-xserve01 looks like a good candidate right now, it still needs changes to become equivilent to bm-xserve02.

bm-xserve01$ uname -a
Darwin bm-xserve01.mozilla.org 8.5.0 Darwin Kernel Version 8.5.0: Sun Jan 22 10:38:46 PST 2006; root:xnu-792.6.61.obj~1/RELEASE_PPC Power Macintosh powerpc
bm-xserve01$
Status: NEW → ASSIGNED
Priority: -- → P2
We use xserve01 for managing the cluster, for the repack tool, for some build verification steps (at least, we used to; I believe l10n verification is still on there), and repacks.

I would seriously rather not change/use xserve01 for this purpose.

Let's find another PPC Mac, or maybe put this on a PPC mac that isn't as critical (1.8.0, maybe?)
Coop: since we found fireball today, and it wasn't doing anything, would it be a good candidate for this purpose, instead of bm-vmware01?
IIRC, fireball is too old hardware-wise to be upgraded to 10.4, which would preclude it from generating useful things like universal binaries. We should verify this with IT.
It would be great if we could setup this mac buildbot slave without disturbing any existing production systems.

mrz will try reimaging fireball to see what happens. Tracking in bug#391742.
Depends on: 391742
IT reimaged fireball and renamed to bm-xserver03.build.mozilla.org. I've now installed buildbot slave (macosx-1.8-slave1) on it. This staging buildbot slave is running fine, and building just fine.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
typo fix: machine name is bm-xserve03.build.mozilla.org
oh, oppps... Nick, thanks for catching that!
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.