window.parent.eval uses "window" scope instead of "window.parent"

RESOLVED DUPLICATE of bug 383682

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 383682
11 years ago
11 years ago

People

(Reporter: FredCK, Unassigned)

Tracking

({regression})

Trunk
x86
Windows Server 2003
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a8pre) Gecko/2007081105 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a8pre) Gecko/2007081105 Minefield/3.0a8pre

Making the following call in an IFRAME:

    window.parent.eval( 'var MyObject = new Object();' ) ;

Will result "MyObject" being created inside "window", not "window.parent".

It seams that this behavior has been introduced with the work done to remove object.prototype.eval. As discussed in other tickets, w.eval (where "w" is a window) should be maintained, but it has no sense if the evaluated expression is not executed in the "w" scope.

Reproducible: Always
(Reporter)

Comment 1

11 years ago
This bug breaks FCKeditor compatibility:
http://dev.fckeditor.net/ticket/1060

Updated

11 years ago
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk

Updated

11 years ago
Flags: blocking1.9?
Keywords: regression

Comment 2

11 years ago
Jesse:  Is your nomination for blocking1.9 a confirmation?
This should be fixed now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Flags: blocking1.9?
Resolution: --- → DUPLICATE
Duplicate of bug: 383682
You need to log in before you can comment on or make changes to this bug.