The default bug view has changed. See this FAQ.

Linux x86_64 startup-notification relocation error gcc-4.2.x

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: Walter Meinl, Assigned: Walter Meinl)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a8pre) Gecko/2007081215 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a8pre) Gecko/2007081215 Minefield/3.0a8pre

/usr/lib/gcc/x86_64-pc-linux-gnu/4.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: n
sWindow.o: relocation R_X86_64_PC32 against `sn_display_new' can not be used whe
n making a shared object; recompile with -fPIC
/usr/lib/gcc/x86_64-pc-linux-gnu/4.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: f
inal link failed: Bad value

Reproducible: Always

Steps to Reproduce:
1. compile minefield with gcc > 4.2
2.
3.
Actual Results:  
relocation error

Expected Results:  
should compile
(Assignee)

Comment 1

10 years ago
Created attachment 276376 [details] [diff] [review]
add the sn headers to the system-wrappers
Attachment #276376 - Flags: review?(benjamin)
Comment on attachment 276376 [details] [diff] [review]
add the sn headers to the system-wrappers

Please use #ifdef instead of ==
Attachment #276376 - Flags: review?(benjamin) → review-
(Assignee)

Comment 3

10 years ago
Created attachment 276513 [details] [diff] [review]
use ifdef (all occasions)

In reply to comment #2)
> (From update of attachment 276376 [details] [diff] [review])
> Please use #ifdef instead of ==
> 
Ups, when I looked at config/system-headers I thought this was desired

benjamin, in this patch version I changed all '==' or '!=' against ifdef or ifndef, working with the sn headers and with native-lcms zlib png and jpeg (cairo not tested, but should work as well)
Since I'm German I want it standardized ;-)
When you think it's overdone I'll attach a patch only ifdef(ed) for startup-notification headers
Attachment #276376 - Attachment is obsolete: true
(Assignee)

Updated

10 years ago
Attachment #276513 - Flags: review?(benjamin)
Attachment #276513 - Flags: review?(benjamin) → review+
(Assignee)

Comment 4

10 years ago
Comment on attachment 276513 [details] [diff] [review]
use ifdef (all occasions)

asking for approval for the trunk. Should be very low risk - and a helper for checkin (if approval +) thanks
Attachment #276513 - Flags: approval1.9?
Keywords: checkin-needed
Assignee: nobody → wuno
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

10 years ago
I am under Gentoo ~amd64 and I have so build errors when emerging Firefox-2.0.0.6, Thunderbird 2.0.0.6 and Xulrunner 1.8.1.6, with gcc-4.2.0, glibc-2.6.1, binutils-2.17.50.0.18.
I have had to disable the "debug" USE flag to build this software.
See : https://bugs.gentoo.org/show_bug.cgi?id=188636
Comment on attachment 276513 [details] [diff] [review]
use ifdef (all occasions)

a=bzbarsky
Attachment #276513 - Flags: approval1.9? → approval1.9+
Checked in on trunk.  Thanks for the patch!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
I think those changes to use ifdef will break things, given the Makefile.  If you want to use ifdef, you have to convert the code that passes through various AC_DEFINEs from configure.in as -Ds to not pass them at all.  So I think what landed will break a bunch of things.

Did anyone test that it didn't?
And note that to test this you need to remove the system-headers directory and clobber any directories that depend on the wrapping.
Yeah, I confirmed locally that the patch broke those tests.  The changes to existing ifdefs should be backed out; the new stuff is fine.
I backed out the ifdef changes in existing code since they broke things (those variables were always defined, sometimes to empty string).
(Assignee)

Comment 12

10 years ago
(In reply to comment #11)
> I backed out the ifdef changes in existing code since they broke things (those
> variables were always defined, sometimes to empty string).
> 

Thanks that you kept an eye on it, I enforced it too much
You need to log in before you can comment on or make changes to this bug.