Missing string jsObjectExpressionError.title in inspector.properties

RESOLVED FIXED

Status

Other Applications
DOM Inspector
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Ronny Perinke, Assigned: crussell)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.5pre) Gecko/20070731 Firefox/2.0.0.7pre (Sephiroth/SSE2)
Build Identifier: 

When you have an error in your expression that should be evaluated in DomI, the user should bee notified - but he won't because the string is missing.

Reproducible: Always

Actual Results:  
Error in Error Console:
--------------
Fehler: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: XStringBundle :: getString :: line 17"  data: no]

Error in console is more detailed:
-----
Error in expression.
*** Failed to get string jsObjectExpressionError.title in bundle: chrome://inspector/locale/inspector.properties

Expected Results:  
Dialog box with appropriate info message.

Regression from bug 352990
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
Confirming, per looking at that patch and per
http://mxr.mozilla.org/comm-central/search?string=jsObjectExpressionError&case=on&find=%2Fmozilla%2Fextensions%2Finspector%2F
Blocks: 352990
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 480448 [details] [diff] [review]
cleanup and use the error name for the alert title
Assignee: nobody → Sevenspade
Status: NEW → ASSIGNED
Attachment #480448 - Flags: review?(neil)

Comment 3

7 years ago
Comment on attachment 480448 [details] [diff] [review]
cleanup and use the error name for the alert title

>+    XPCU.getService("@mozilla.org/embedcomp/prompt-service;1",
>+                    "nsIPromptService")
>+      .alert(window, ex.name, ex.message);
[Indentation looks odd. Try an extra two spaces?]
Attachment #480448 - Flags: review?(neil) → review+
> Comment on attachment 480448 [details] [diff] [review]
> cleanup and use the error name for the alert title
> 
> >+    XPCU.getService("@mozilla.org/embedcomp/prompt-service;1",
> >+                    "nsIPromptService")
> >+      .alert(window, ex.name, ex.message);
> [Indentation looks odd. Try an extra two spaces?]

I just split it into two lines.  I'm not a fan of lining up the dots, because the second part isn't analogous to the getService part, because it's not operating on XPCU.

Pushed http://hg.mozilla.org/dom-inspector/rev/c0b6ded88689(In reply to comment #3)
Blocks: 592530
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
> Pushed http://hg.mozilla.org/dom-inspector/rev/c0b6ded88689(In reply to comment
> #3)

That's http://hg.mozilla.org/dom-inspector/rev/c0b6ded88689.
You need to log in before you can comment on or make changes to this bug.