In Gran Paradiso Alpha 7, Dropdown lists/comboboxes/et cetera are not themed

RESOLVED INVALID

Status

()

Core
Widget: Gtk
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Zak, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7) Gecko/2007080209 GranParadiso/3.0a7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a7) Gecko/2007080209 GranParadiso/3.0a7

In Gran Paradiso Alpha 7, Dropdown lists/comboboxes/et cetera in web sites do not take on the native GTK style

Is this the fault of the web page or Firefox? Because some pages do have comboboxes themed

Reproducible: Sometimes

Steps to Reproduce:
1. Go to a site with comboboxes/dropdown lists/et cetera (like http://kde-look.org/)
2. Look at the comboboxes/dropdown lists, they do not follow the native GTK style

Actual Results:  
comboboxes/dropdown lists/et cetera are not themed in the GTK style

Expected Results:  
comboboxes/dropdown lists/et cetera should be themed, shouldn't they? But they are on the bug reporting page, as I have just seen....
Component: OS Integration → Widget: Gtk
Product: Firefox → Core
QA Contact: os.integration → gtk
(Reporter)

Comment 1

11 years ago
Okay since no one really seems to care... (isn't fixed in nightlies, as far as I can see....)

There is a CSS file that sets the button style's to some custom thing and the comboboxes, could we use this, but instead call the native widgets?
 
URL: http://ubuntuforums.org/showthread.php?t=369596

This also fixes an issue I saw where if text areas/comboboxes (that do get themed) have a color set when you focus them, revert to the old style. 
(Reporter)

Comment 2

11 years ago
Okay... more ideas... is it related to a naming issue...? Like combobox, listbox, dropdown list..., but we theme only, say, the first two?

Comment 3

11 years ago
Its because that site sets specific CSS styles on their widgets, so Gecko draws the widget itself instead of calling the native theme to make sure that every style rule is honoured. Its intentional and nothing can be done about it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

11 years ago
Created attachment 284710 [details]
Screenshot of Windows behavior.

This what Firefox 2 Windows does... also, Wikipedia has this issue on Linux too, but anywho.... I can't code worth ****, so I wouldn't know....
(Reporter)

Comment 5

11 years ago
Created attachment 284867 [details]
This is What a colored combobox reverting to the ugly widgets looks like in Windows

Again, something is fishy here, shouldn't we be getting an ugly widgets here? Looks the Firefox dev's did some hacking for Windows, but won't for Linux....
(Reporter)

Comment 6

11 years ago
Hmm, okay, what if we do something like (pseudocode here)
While widget is resized but not colored Do
Draw the widget with the GTK theme
Endwhile
While the widget is colored, or colored & resized Do
Draw the ugly widget
Endwhile
?

It'd be better then the current system. 
(Reporter)

Comment 7

11 years ago
I've been thinking it over, and is it because you know what windows Widgets look like, and that's why you have the hack? If so, why not just use the above method I suggested? And with that, this bug really isn't "Invalid", so I'm reopening it *Shots* *Cursing*.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Comment 8

11 years ago
Reopening this bug will not accomplish anything. These sites are using special styles and for Gecko to honour them we must not use native widgets. Windows dropdown lists are much different from Linux in that they do use a field and button so they don't look as ugly on that platform.

That pseudocode you have above is exactly what we do now. If its coloured or it has a different border we cannot use native widgets.
(Reporter)

Comment 9

11 years ago
What load of utter BS! It's true then, I guess, Mozilla doesn't give a **** and a 1/2 to Linux anymore. You know perfectly well you could theme these widgets on Linux, but you won't it's "not worth the time or money".

(Reporter)

Comment 10

11 years ago
Just one question before I go off to rant about this on certain blogs:

What about Visual Styles in Windows where the listboxes look like GTK Listboxes, EG this style:
http://lennard.deviantart.com/art/Milk-2-0-5420575

Comment 11

11 years ago
Stop your nonsense! I didn't get paid by Mozilla to implement native Linux widgets, and this was just the way Gecko was designed so, for the last time, there is nothing I can do.

This is the road we have to take so that the webmaster's styles are respected. Native widgets do not do that. We have to do the same thing on Mac OS X.

As for that Windows theme, I'm sure that if you go to websites where their option lists have styles applied to them they will no longer look like GTK boxes.
(Reporter)

Comment 12

11 years ago
Alright then. Acceptable answer.... Though I'm sure if you called for help to the community, you'd get a fix rather quickly....

Anywho! Thanks for the info. But, I'll stick to Konqueror unless they go haywire...

Now, I'm off to test that Visual Style. 
(Reporter)

Comment 13

11 years ago
Damn you're good at making people feel guilty! Sorry for the little er outburst. 
As Michael said, this is invalid.  The issue is that there is no way to draw the native widget while honoring the page's color style, since GTK's combobox widget is a single thing that needs to be drawn as a unit.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.