Remove TYPE_PLUGIN from the extension manager

VERIFIED FIXED in mozilla1.9alpha8

Status

()

Toolkit
Add-ons Manager
VERIFIED FIXED
10 years ago
9 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

({dev-doc-complete, relnote})

Trunk
mozilla1.9alpha8
dev-doc-complete, relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Since there are no plugin type EM managed items I know of I'd like to remove the plugin type from the EM and just require EM managed plugins to install as extensions.  This would allow providing ui for enabling / disabling plugins in the plugins view without displaying uninstall, etc. for plugins and for EM extensions with plugins it would just behave as an extension. Also, plugins included with extensions today (e.g. IE Tab, perhaps others) will show up in both views anyways.
Flags: blocking-firefox3?
Does this affect bug 392084?
(In reply to comment #1)
> Does this affect bug 392084?
Not at all
Created attachment 276596 [details] [diff] [review]
patch rev 1

I'm going to discuss this with a few people before requesting review
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
What about TYPE_PLUGIN in toolkit/mozapps/extensions/content/extensions.js ?
(In reply to comment #4)
> What about TYPE_PLUGIN in toolkit/mozapps/extensions/content/extensions.js ?
I threw that up here since I am cleaning up my tree. Also, I search lxr before removing things so no reason to worry about my missing things like this.
Duplicate of this bug: 392265
Blocks: 391730
Created attachment 276924 [details] [diff] [review]
patch
Attachment #276596 - Attachment is obsolete: true
Attachment #276924 - Flags: review?(benjamin)
Comment on attachment 276924 [details] [diff] [review]
patch

Forgot to include the extensions.xml changes
Attachment #276924 - Flags: review?(benjamin)
Created attachment 276928 [details] [diff] [review]
patch rev3 -w (also cleaned up some whitespace)
Attachment #276924 - Attachment is obsolete: true
Attachment #276928 - Flags: review?(benjamin)
Created attachment 276929 [details] [diff] [review]
patch
Attachment #276928 - Flags: review?(benjamin) → review+
Checked in to trunk

Checking in mozilla/toolkit/mozapps/extensions/public/nsIExtensionManager.idl;
/cvsroot/mozilla/toolkit/mozapps/extensions/public/nsIExtensionManager.idl,v  <--  nsIExtensionManager.idl
new revision: 1.49; previous revision: 1.48
done
Checking in mozilla/toolkit/mozapps/extensions/src/nsExtensionManager.js.in;
/cvsroot/mozilla/toolkit/mozapps/extensions/src/nsExtensionManager.js.in,v  <--  nsExtensionManager.js.in
new revision: 1.237; previous revision: 1.236
done
Checking in mozilla/toolkit/mozapps/extensions/content/extensions.js;
/cvsroot/mozilla/toolkit/mozapps/extensions/content/extensions.js,v  <--  extensions.js
new revision: 1.134; previous revision: 1.133
done
Checking in mozilla/browser/base/content/safeMode.js;
/cvsroot/mozilla/browser/base/content/safeMode.js,v  <--  safeMode.js
new revision: 1.10; previous revision: 1.9
done
Checking in mozilla/toolkit/themes/pinstripe/mozapps/extensions/extensions.css;
/cvsroot/mozilla/toolkit/themes/pinstripe/mozapps/extensions/extensions.css,v  <--  extensions.css
new revision: 1.26; previous revision: 1.25
done
Checking in mozilla/toolkit/themes/winstripe/mozapps/extensions/extensions.css;
/cvsroot/mozilla/toolkit/themes/winstripe/mozapps/extensions/extensions.css,v  <--  extensions.css
new revision: 1.30; previous revision: 1.29
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: blocking-firefox3?
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 M8

Updated

10 years ago
Keywords: dev-doc-needed, relnote

Updated

10 years ago
Keywords: dev-doc-needed → dev-doc-complete
verified fixed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8) Gecko/2007091216 GranParadiso/3.0a8
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.