Closed Bug 392144 Opened 13 years ago Closed 12 years ago

"ASSERTION: JS object but unknown to the JS GC" and "ASSERTION: Fault in cycle collector: script pointer traversal failed"

Categories

(Core :: XPConnect, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 386912

People

(Reporter: jruderman, Assigned: peterv)

References

Details

(Keywords: assertion)

Attachments

(2 files)

During EM restart, I got these three assertions.  I wasn't able to reproduce, but  I happened to be testing the patch for bug 336517, so I got stack traces :)

2 * ###!!! ASSERTION: JS object but unknown to the JS GC?: 'mObjRefcounts->Get(p) > 0', file /Users/jruderman/trunk/mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 611

(since dbaron asked: both on the same line, in nsXPConnect::ToParticipant)

###!!! ASSERTION: Fault in cycle collector: script pointer traversal failed (ptr: 2260820)
: 'Not Reached', file /Users/jruderman/trunk/mozilla/xpcom/base/nsCycleCollector.cpp, line 939
Jesse, what's your jsgc.c:2037 look like?

/be
My jsgc.c isn't modified.  Line 2037 is:

JS_CALL_OBJECT_TRACER(trc, acx->globalObject, "global object");

I don't know if this will be useful to anyone, but during a scan of msn on CentOS4 where I was bookmarking every page visited, I saw the following contiguous assertions. They are not reproducible by simply loading the page where they occurred.

###!!! ASSERTION: JS object but unknown to the JS GC?: 'mObjRefcounts->Get(p) > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 611
###!!! ASSERTION: JS object but unknown to the JS GC?: 'mObjRefcounts->Get(p) > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 611
###!!! ASSERTION: JS object but unknown to the JS GC?: 'refcount > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 717
###!!! ASSERTION: Fault in cycle collector: zero refcount (ptr: a5eb0c0)
: 'Not Reached', file mozilla/xpcom/base/nsCycleCollector.cpp, line 954
###!!! ASSERTION: JS object but unknown to the JS GC?: 'refcount > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 717
###!!! ASSERTION: Fault in cycle collector: zero refcount (ptr: 9ce7c80)
: 'Not Reached', file mozilla/xpcom/base/nsCycleCollector.cpp, line 954
###!!! ASSERTION: JS object but unknown to the JS GC?: 'mObjRefcounts->Get(p) > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 611
###!!! ASSERTION: JS object but unknown to the JS GC?: 'mObjRefcounts->Get(p) > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 611
###!!! ASSERTION: JS object but unknown to the JS GC?: 'mObjRefcounts->Get(p) > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 611
###!!! ASSERTION: JS object but unknown to the JS GC?: 'refcount > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 717
###!!! ASSERTION: Fault in cycle collector: zero refcount (ptr: a5ead00)
: 'Not Reached', file mozilla/xpcom/base/nsCycleCollector.cpp, line 954
###!!! ASSERTION: JS object but unknown to the JS GC?: 'refcount > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 717
###!!! ASSERTION: Fault in cycle collector: zero refcount (ptr: a5eb480)
: 'Not Reached', file mozilla/xpcom/base/nsCycleCollector.cpp, line 954
###!!! ASSERTION: JS object but unknown to the JS GC?: 'mObjRefcounts->Get(p) > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 611
###!!! ASSERTION: JS object but unknown to the JS GC?: 'refcount > 0', file mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 717
###!!! ASSERTION: Fault in cycle collector: zero refcount (ptr: a5eb4a0)
: 'Not Reached', file mozilla/xpcom/base/nsCycleCollector.cpp, line 954



I think you need stack traces for those to be useful.  Want to turn on XPCOM_DEBUG_BREAK=stack and try again?  (Depending on your OS, you may need to run mozilla/tools/rb/fix-*-stack.pl once you get a rough stack trace from Firefox.)
These all occurred while loading the referenced page but are not reproducible simply by loading that page by itself.
Peter, could you have a look at this. Would be great to know what's going on at least to see if this might possibly not be a blocker. Though it does look very bad indeed.

Might this even be fixed by your patch to do tracing differently?
Assignee: nobody → peterv
Flags: blocking1.9? → blocking1.9+
Do we care about this for b1?
This should be fixed by the patch for bug 401687 and looks like a dupe of bug
386912.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 386912
You need to log in before you can comment on or make changes to this bug.