first run migration / import from opera and safari browser are slow, history import should use "run in batch"

VERIFIED FIXED in Firefox 3 alpha8

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({perf})

Trunk
Firefox 3 alpha8
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox3 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

first run migration / import from opera and safari browser are slow, history import should use "run in batch"

need to make the fix for bug #392003 to the other browsers (bug #392003 was just for IE)

nsOperaProfileMigrator.cpp:        hist->AddPageWithDetails(uri, title.get(), lastVisitDate);
nsSafariProfileMigrator.cpp:          history->AddPageWithDetails(uri, title.get(), lastVisitTime);
Flags: blocking-firefox3?
Created attachment 276671 [details] [diff] [review]
fix for safari

the IE-history-import part of https://bugzilla.mozilla.org/attachment.cgi?id=276458 for safari.  (opera to come later, when I'm on a pc)
Attachment #276671 - Flags: review?
Attachment #276671 - Flags: review? → review?(sayrer)

Updated

10 years ago
Attachment #276671 - Flags: review?(sayrer) → review+
safari fixed:

cvs commit: Examining .
Checking in nsSafariProfileMigrator.cpp;
/cvsroot/mozilla/browser/components/migration/src/nsSafariProfileMigrator.cpp,v  <--  nsSafariProfileMigrator.cpp
new revision: 1.43; previous revision: 1.42
done
Checking in nsSafariProfileMigrator.h;
/cvsroot/mozilla/browser/components/migration/src/nsSafariProfileMigrator.h,v  <--  nsSafariProfileMigrator.h
new revision: 1.20; previous revision: 1.19
done
Assignee: nobody → sspitzer
Created attachment 276743 [details] [diff] [review]
fix for opera
Attachment #276743 - Flags: review?(sayrer)
Status: NEW → ASSIGNED
Target Milestone: Firefox 3 M9 → Firefox 3 M8
Comment on attachment 276743 [details] [diff] [review]
fix for opera

r=me, thanks seth
Attachment #276743 - Flags: review?(sayrer) → review+
opera patch landed.

since both opera and safari are fixed (note bug #392003 covers IE), marking this bug as fixed.

cvs commit: Examining browser/components/migration/src
? browser/components/migration/src/diff.txt
Checking in browser/components/migration/src/nsOperaProfileMigrator.cpp;
/cvsroot/mozilla/browser/components/migration/src/nsOperaProfileMigrator.cpp,v
<--  nsOperaProfileMigrator.cpp
new revision: 1.68; previous revision: 1.67
done
Checking in browser/components/migration/src/nsOperaProfileMigrator.h;
/cvsroot/mozilla/browser/components/migration/src/nsOperaProfileMigrator.h,v  <-
-  nsOperaProfileMigrator.h
new revision: 1.21; previous revision: 1.20
done
Blocks: 380307
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Flags: in-litmus?
Keywords: perf
Resolution: --- → FIXED

Updated

10 years ago
Flags: blocking-firefox3? → blocking-firefox3+
Litmus triage team: adding tracy to this bug.

Comment 7

10 years ago
verified with - Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a8pre) Gecko/2007091304 Minefield/3.0a8pre
Status: RESOLVED → VERIFIED
Test cases were updated on litmus for 3.x test runs for regression testing.

For 3.0,
https://litmus.mozilla.org/show_test.cgi?id=1647

For 3.1,
https://litmus.mozilla.org/show_test.cgi?id=6019
Flags: in-litmus? → in-litmus+
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.