use nsIFilePicker instead of nsFileWidget in Editor

VERIFIED DUPLICATE of bug 47553

Status

()

P3
normal
VERIFIED DUPLICATE of bug 47553
19 years ago
17 years ago

People

(Reporter: m_kato, Assigned: kinmoz)

Tracking

Trunk
x86
All
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
nsFileWidget is obsolete class.
So we should rewrite to nsIFilePicker in "Open dialog" and "Save dialog".
(Reporter)

Comment 1

19 years ago
Created attachment 8661 [details] [diff] [review]
a patch

Comment 2

19 years ago
assigning to brade to review patch
Assignee: beppe → brade
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → M17

Updated

19 years ago
Status: NEW → ASSIGNED

Updated

19 years ago
Keywords: patch

Comment 3

19 years ago
Suggest consideration for nsbeta2 since there's already a patch and since there
are numerous quite annoying bugs with the old filepicker.
Keywords: nsbeta2

Comment 4

19 years ago
[nsbeta2-] since the bad behavior isn't described. Also, since the patch was 
written by a mozilla contributor, it could go in through mozilla.org
Whiteboard: [nsbeta2-]

Comment 5

19 years ago
reassign to kin to review patch, and get reviewer to submit through mozilla.org
Assignee: brade → kin
Status: ASSIGNED → NEW
Keywords: nsbeta2
Whiteboard: [nsbeta2-]
(Assignee)

Comment 6

19 years ago
Will look at this for M18.
Status: NEW → ASSIGNED
Target Milestone: M17 → M18

Comment 7

19 years ago
The bad behavior is the file list is not localizable. waterson, please approve
for check in.

Updated

19 years ago
Blocks: 46684
(Reporter)

Updated

19 years ago
Blocks: 47551
(Reporter)

Comment 8

19 years ago
please dup of 47553

Comment 9

19 years ago
dup

*** This bug has been marked as a duplicate of 47553 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 10

19 years ago
verified in 9/6 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.