Password manager doesn't appear when password contains broken entries

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
12 years ago
10 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Thunderbird 2.0.0.6 OS/2

If one or more of the entries in the password file (signons.txt or *.s) is garbled, the password manager dialog does not appear. Instead one just sees a quick flicker and it disappears again. No error is left in the Error Console.

To reproduce:
1. Edit one or more entries in *.s or signons.txt and break them by
   adding a few extra characters to the encrypted password.
2. (Re)Start Thunderbird.
3. Go to Tools->Options->Privacy->Passwords->Edit Saved Passwords

Actual result:
Instead of the password dialog one only sees a short flicker. Nothing in the Error Console.

Expected result:
Either
   - Show the password manager without the garbled entry/entries.
or
   - Show an error message that some entries are broken.

Comment 1

12 years ago
This seems to be not OS/2 only, I can reproduce it at least on linux.
Strangly enough, after editing signon.txt on linux I was asked to enter a password. Since I wanted to look, if this bug is also present on linux I canceled to enter a new password, but TB downloaded my mails regardless that signon.txt was changed (maybe it just ignored the trailing characters I entered). Anyway, with the wrong entry in signon.txt I couldn't open the password manager, just as you described for OS/2 (removing the trailing characters brought the password manager back)

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

12 years ago
It's a cross-platform problem, and seems to be Thunderbird only. Firefox 2.0.0.6 does display its Password Manager, just without the garbled entries.
OS: OS/2 → All
Hardware: PC → All
Since ff is fine, bug 239131 would surely fix this.
Blocks: 239131
Version: unspecified → 2.0
Yes, the new pwmgr should generally fix this. There's only so much you can do when the file is corrupted (perhaps silently so), but it shouldn't ever entirely bust the manager UI like this.
No longer blocks: 239131
Depends on: 239131
Not sure if this is still valid, but since Thunderbird is now using the toolkit password manager, this should go in the toolkit product.
Component: Preferences → Password Manager
Product: Thunderbird → Toolkit
QA Contact: preferences → password.manager
Version: 2.0 → Trunk
Let's call the WFM. The storage module suppresses any errors encountered in the file, so the worst that will happen is you get an empty window if all entries are corrupt.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.