Closed Bug 392387 Opened 17 years ago Closed 17 years ago

New Event / New Task context menu command no longer works

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: Fallen)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

New Event / New Task context menu command no longer works using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.7pre) Gecko/20070815 Calendar/0.7pre

Steps to Reproduce:
1. Start Sunbird with clean profile
2. Right click into main calendar view, task list, minimonth or unifinder
3. Select New Event resp. New Task from the context menu

Actual Results:
Nothing happens. No errors shown in Error Console.

Expected Results:
New Event / New Task dialog opens

Additional Information:
Works in Sunbird 0.7pre (2007081406)
Fails in Sunbird 0.7pre (2007081506)
Same failure in Lightning 0.7pre (2007081505) regarding the context menu of the main calendar view. For this failure the console shows:

  Error: ltnCreateEvent is not defined
  Source File: chrome://messenger/content/messenger.xul Line: 1
Attached patch Fix Context menus (obsolete) β€” β€” Splinter Review
Wow it looks like I really broke a lot with that patch, sorry guys. This bit fixes the context menus. Sunbird had a lot of them not working since I overlooked some command observers.

As far as I could see, lightning has the correct names for all command observers.
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #276905 - Flags: review?(michael.buettner)
Blocks: 388405
OS: Windows 2000 → All
Hardware: PC → All
Attached patch Fix Context menus β€” β€” Splinter Review
Sorry, missed the last comment. New patch to also fix lightning. Checked for all functions in calendar-management.js that I removed.
Attachment #276905 - Attachment is obsolete: true
Attachment #276908 - Flags: review?(michael.buettner)
Attachment #276905 - Flags: review?(michael.buettner)
Comment on attachment 276908 [details] [diff] [review]
Fix Context menus

looks good -> r=mickey.
Attachment #276908 - Flags: review?(michael.buettner) → review+
Checked in on HEAD and MOZILLA_1_8_BRANCH

-> FIXED (hopefully ;)
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.7
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.7pre)
Gecko/20070817 Calendar/0.7pre.

Verified using Lightning 0.7pre (2007081705) with Thunderbird 2.0.0.7pre
(20070817) on Windows 2000.
Status: RESOLVED → VERIFIED
Verified on linux with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.7pre) Gecko/20070906 Calendar/0.7pre
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: