Check for updates - hangs & creates JS Console errors

VERIFIED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
major
VERIFIED WORKSFORME
11 years ago
10 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007081517 Minefield/3.0a8pre Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007081517 Minefield/3.0a8pre Firefox/3.0

Checking for updates to Add-ons is causing it to hang with nothing being checked, and is creating errors in the JS Console, both on 'Open' of the Add-ons Manager and then more when clicking 'Check for updates' 

Reproducible: Always

Steps to Reproduce:
1. Open Add-ons
2. Open JS Console and note error from open of the Add-ons
3. Click Check for updates on extensions, note the flurry of errors and that the progress meter does not advance, and the checking for updates is 'hung'. 


Expected Results:  
No errors, and check for updates should complete.

This appears to have regressed:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007081517 Minefield/3.0a8pre Firefox/3.0 ID:2007081517 (17:57)- Broken

EDIT: Previous build 2007081517 (hour 17:27) is OK

Suspect the checkin for https://bugzilla.mozilla.org/show_bug.cgi?id=271559 has caused the problem. 

Opening Add-ons creates:
Error: Components.classes['@mozilla.org/extensions/blocklist;1'] has no properties
Source file: file:///C:/Program%20Files/Minefield/components/nsExtensionManager.js
Line: 7630

Checking for updates creates: (appears that one error per extension/theme/plugin is created)
Error: '[JavaScript Error: "Components.classes['@mozilla.org/extensions/blocklist;1'] has no properties" {file: "file:///C:/Program%20Files/Minefield/components/nsExtensionManager.js" line: 7630}]' when calling method: [nsIExtensionManager::update] = NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS
Source file: chrome://mozapps/content/extensions/extensions.js
Line: 1725
Looks like we aren't packaging the blocklist service on windows.
Blocks: 271559
Status: UNCONFIRMED → NEW
Ever confirmed: true
Ok I lie, that looks right.
(Reporter)

Updated

11 years ago
Keywords: regression
This worked for me with
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007081521

Can this still be reproduced?

Comment 4

11 years ago
With

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081522 Minefield/3.0a8pre ID:2007081522

Opening Add-Ons gives me 7 of the following message:

Error: not well-formed
Source code:
<div xmlns="http://www.w3.org/1999/xhtml">The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the <A HREF=http://www.apple.com/quicktime/>QuickTime</A> Web site.</

Checking for updates gives me 9 of the following message:

Error: 'Component does not have requested interface' when calling method: [nsIInterfaceRequestor::getInterface] = NS_NOINTERFACE

Note: I'm using Console2 0.3.7+.
(In reply to comment #4)
> With
> 
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007081522
> Minefield/3.0a8pre ID:2007081522
> 
> Opening Add-Ons gives me 7 of the following message:
> 
> Error: not well-formed
> Source code:
> <div xmlns="http://www.w3.org/1999/xhtml">The QuickTime Plugin allows you to
> view a wide variety of multimedia content in Web pages. For more information,
> visit the <A HREF=http://www.apple.com/quicktime/>QuickTime</A> Web site.</
That is bug 391666 and is just informational

> Checking for updates gives me 9 of the following message:
> 
> Error: 'Component does not have requested interface' when calling method:
> [nsIInterfaceRequestor::getInterface] = NS_NOINTERFACE
That is bug 374499

So, this works for two people so far.

Can anyone reproduce the errors reported in comment #0?

Comment 6

11 years ago
After disabling and then uninstalling Console2, getting the same messages as in comment 4, plus (upon opening Addons):

Error: bc has no properties
Source File: chrome://global/content/console.js
Line: 61

Not seeing the errors in comment 0 though.
That has nothing to do with this bug.

Can anyone reproduce the errors reported in comment #0?
I can't, but I'm not sure that helps you.  (Windows Vista, Minefield, with four extensions and two themes checked.)
Perhaps the build Jim got was mid-checkin of bug 271559.

Jim, when you get a chance try a newer build and post whether the problem is still present.
OK, I just tried this hourly, and its not doing it now.  Sorry for the confusion.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007081523 Minefield/3.0a8pre Firefox/3.0 ID:2007081523 (23:34) build.

Marking WFM
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
Verified worksforme.
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.