All users were logged out of Bugzilla on October 13th, 2018

Print Preview hang on particular wikipedia page

RESOLVED DUPLICATE of bug 285608

Status

()

--
critical
RESOLVED DUPLICATE of bug 285608
11 years ago
11 years ago

People

(Reporter: wimbaster, Unassigned)

Tracking

({hang})

1.8 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

On page http://en.wikipedia.org/wiki/Air
File -> Print Preview
Firefox freezes and fills up memory.

Reproducible: Always

Steps to Reproduce:
1. Open page http://en.wikipedia.org/wiki/Air
2. On Firefox 2.0.0.6 File -> Print Preview
3. Firefox freezes and fills up memory.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
(Reporter)

Comment 1

11 years ago
OS - Windows 2000, Windows XP, Linux

Comment 2

11 years ago
The same situation happens in Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.6) Gecko/20070208 Mandriva/2.0.0.6-1mdv2007.1 (2007.1) Firefox/2.0.0.6 
CPU load is about 90-100% on both cores of Athlon 64 X2 Dual-Core 5600+ . However  the load is changing, like some real activity is still going on in FF.  But nothing visible happens except more and more memory eaten by Firefox.

Konqueror 3.5.6 quickly forms print preview of the same page. So it seems more like Firefox problem. 

Comment 3

11 years ago
Confirming on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6 ID:2007072518

Comment 4

11 years ago
Works fine on Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007081505 Minefield/3.0a8pre

Updated

11 years ago
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: General → Print Preview
Depends on: 350684
Ever confirmed: true
Keywords: hang
OS: Windows 2000 → All
Product: Firefox → Core
QA Contact: general → printing
Version: 2.0 Branch → 1.8 Branch

Comment 5

11 years ago
Hang seems related to the images on that page, I got no hang when I disallowed loading images. Same bug seen on the german version http://de.wikipedia.org/wiki/Erdatmosph%C3%A4re
This page contains consecutive floats with overflow:hidden, hangs on branch with Print Preview (100% CPU, memory steadily increasing) and doesn't hang with current trunk.

Marking as duplicate.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 285608
You need to log in before you can comment on or make changes to this bug.