Closed Bug 392487 Opened 14 years ago Closed 14 years ago

Allow Venkman (javascript debugger) to be an optional install.

Categories

(SeaMonkey :: Installer, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file, 1 obsolete file)

Once bug 392475 is ready to land, we'll need this as well.

After bug 392475 lands, Venkman will be built to extensions/ so we'll need to change our packaging files to pick it up from there. Additionally if we make it an optional install again, that'll bring us back to parity with the SeaMonkey 1.x builds wrt Venkman install options.

The attached patch should do this. Note that the venkman icon is still SeaMonkey specific so I'm not including that in the optional packaging.

Note for testing this you'll also need the patch from bug 392475 applied (and you'll probably want to remove chrome/venkman.jar and components/venkman-service.js from the dist/bin/ directory).
Attachment #276998 - Flags: review?(bugzilla)
Similar to previous patch, with a couple of fixes to custom.nsi and hopefully a reasonable layout on the components page.
Attachment #276998 - Attachment is obsolete: true
Attachment #277018 - Flags: review?(bugzilla)
Attachment #276998 - Flags: review?(bugzilla)
Comment on attachment 277018 [details] [diff] [review]
Change venkman to an optional install v2

>===================================================================
>RCS file: /cvsroot/mozilla/suite/installer/windows/packages,v
>retrieving revision 1.30
>diff -u -p -r1.30 packages
>--- suite/installer/windows/packages	14 Aug 2007 16:47:44 -0000	1.30
>+++ suite/installer/windows/packages	16 Aug 2007 21:19:38 -0000
>@@ -348,6 +348,8 @@ bin\chrome\icons\default\jpeg-file.ico
> bin\chrome\icons\default\script-file.ico
> bin\chrome\icons\default\xml-file.ico
> bin\chrome\icons\default\xul-file.ico
>+; Although venkman-window is an extension, its icon is still suite-specific
             ^^^^^^^^^^^^^^
Make that "Venkman" :)

>+bin\chrome\icons\default\venkman-window.ico
> ;-bin\chrome\comm\content\editor\EditorInitPage.html
> ;-bin\chrome\comm\editor\content\EditorInitPagePlain.html
> ;Include this for "debug" testing - remove for actual beta release:


>Index: suite/locales/en-US/installer/windows/custom.properties
>===================================================================
>RCS file: /cvsroot/mozilla/suite/locales/en-US/installer/windows/custom.properties,v
>retrieving revision 1.2
>diff -u -p -r1.2 custom.properties
>--- suite/locales/en-US/installer/windows/custom.properties	30 Jul 2007 17:49:51 -0000	1.2
>+++ suite/locales/en-US/installer/windows/custom.properties	16 Aug 2007 21:19:39 -0000
>@@ -57,6 +57,8 @@ DEBUGQA_TITLE=Debug and QA UI
> DEBUGQA_TEXT=Provides additional debug and QA UI for SeaMonkey development.
> PALMSYNC_TITLE=Palm Synchronization Extension
> PALMSYNC_TEXT=Extension for enabling the address book to synchronize with a palm device.
>+VENKMAN_TITLE=JavaScript Debugger
>+VENKMAN_TEXT=JavaScript debugger and profiler

I would use "JavaScript Debugger and Profiler" here, but that's just my linguistic instinct.

r+
Attachment #277018 - Flags: review?(bugzilla) → review+
Duplicate of this bug: 393712
Patch checked in -> fixed.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.