Event dialog: start/end time get lost if 'all day event' is ticked/de-ticked once

VERIFIED FIXED in 1.0b1

Status

Calendar
Dialogs
--
minor
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: juergen.edner, Assigned: Decathlon)

Tracking

Sunbird 0.7
1.0b1

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Thunderbird v2.0.0.6 (20070728) / Lightning v0.7pre (2007081804)

If the 'all day event' box is ticked the start/end time get lost and is set to 00:00h instead. If the box is de-ticked again the time will not be restored properly.

Reproducible: Always

Steps to Reproduce:
1. create a new event
2. tick 'all day event' box
3. de-tick 'all day event' box
Actual Results:  
start/end time get lost.

Expected Results:  
start/end time will be restored properly.

Updated

10 years ago
Summary: Lightning - start/end time get lost if 'all day event' ist ticked/de-ticked once → [Proto] Event dialog: start/end time get lost if 'all day event' ist ticked/de-ticked once
I can confirm the behavior with Lightning 0.8pre (2007110903) on WinXP. Christian, what is the expected behavior?
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Calendar Views → General
Ever confirmed: true
OS: Windows XP → All
QA Contact: views → general
Hardware: PC → All
Summary: [Proto] Event dialog: start/end time get lost if 'all day event' ist ticked/de-ticked once → [Proto] Event dialog: start/end time get lost if 'all day event' is ticked/de-ticked once
Component: General → Theme
Product: Calendar → Firefox
Target Milestone: --- → Firefox 3
Version: unspecified → Trunk
Oops, sorry, my bad, returning to the right component, awfully sorry about stomping your target milestone, please send hatemail to this address :(
Component: Theme → General
Product: Firefox → Calendar
Target Milestone: Firefox 3 → ---
Version: Trunk → Sunbird 0.7
Summary: [Proto] Event dialog: start/end time get lost if 'all day event' is ticked/de-ticked once → Event dialog: start/end time get lost if 'all day event' is ticked/de-ticked once
Component: General → Dialogs
QA Contact: general → dialogs

Comment 3

8 years ago
I can confirm on Sunbird 0.9, Mac OS X 10.5.
(Assignee)

Comment 4

8 years ago
Created attachment 399055 [details] [diff] [review]
patch

Could I have an opinion here?
I think the patch covers all possible cases and, if the event is an all-day one, when the checkbox is de-ticked off, it sets the start time to next hour (like a new event).
Unfortunately I used two global variables (that I know aren't the best choice).

By the way, in the file 'calendar-event-dialog.js' there are two global variables that aren't used anywhere:
gUserID
gOrganizerID
Attachment #399055 - Flags: review?(philipp)
Assignee: nobody → bv1578
Status: NEW → ASSIGNED
Comment on attachment 399055 [details] [diff] [review]
patch

The first time I tested the patch, the date was reset to midnight, but afterwards I could not reproduce this. Maybe I just clicked in the wrong time slot or so. Further testing lets it look fine.

The only way we could "get rid" of those globals is to set the variables on the function object, i.e

onUpdateAllDay.oldStartTime = gStartTime.clone()

but given the large amount of globals we have I doubt its worth the extra effort.

Anyway, I'd like to have the globals prefixed with "g" and make the allday variable use "let". I'll change this before checkin.

r=philipp
Attachment #399055 - Flags: review?(philipp) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/d595d8b75570>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0
Target Milestone: 1.0 → 1.0b1

Comment 7

8 years ago
verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.9pre) Gecko/20100224 Calendar/1.0b2pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.