Closed Bug 392737 Opened 12 years ago Closed 10 years ago

Event dialog: No 'save and close' function in the new event file menu

Categories

(Calendar :: Dialogs, defect, trivial)

defect
Not set
trivial

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: juergen.edner, Assigned: Tobbi)

Details

(Whiteboard: [good first bug])

Attachments

(1 file, 1 obsolete file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Thunderbird v2.0.0.6 (20070728) / Lightning v0.7pre (2007081804)

In the 'new event' dialog it is not possible to choose the 'save and close' function via the menu bar/file menu, although a 'save and close' button exists in toolbar.

Reproducible: Always

Steps to Reproduce:
1. create a new event
2. open the file menu from the menu bar to save and close the newly created event.
3. 
Actual Results:  
the desired function doesn't exist in the file menu.

Expected Results:  
It should also be possible to choose 'save and close' via the file menu.
Summary: Lightning - no 'save and close' function in the new event file menu → [Proto] Event dialog: no 'save and close' function in the new event file menu
Christian, what is your opinion on this enhancement request?
Component: Calendar Views → General
OS: Windows XP → All
QA Contact: views → general
Hardware: PC → All
Component: General → Theme
Product: Calendar → Firefox
Target Milestone: --- → Firefox 3
Version: unspecified → Trunk
Oops, sorry, my bad, returning to the right component, awfully sorry about stomping your target milestone, please send hatemail to this address :(
Component: Theme → General
Product: Firefox → Calendar
Target Milestone: Firefox 3 → ---
Version: Trunk → Sunbird 0.7
Keywords: uiwanted
Version: Sunbird 0.7 → unspecified
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [Proto] Event dialog: no 'save and close' function in the new event file menu → Event dialog: No 'save and close' function in the new event file menu
Whiteboard: [good first bug]
Component: General → Dialogs
QA Contact: general → dialogs
Assignee: nobody → tobbi.bugs
Status: NEW → ASSIGNED
Attachment #406069 - Flags: review?(philipp)
Comment on attachment 406069 [details] [diff] [review]
[after beta] Adds a menu item to the file menu as well as the translations

I'll review this after the beta, since it contains strings.
Attachment #406069 - Attachment description: Adds a menu item to the file menu as well as the translations → [after beta] Adds a menu item to the file menu as well as the translations
Comment on attachment 406069 [details] [diff] [review]
[after beta] Adds a menu item to the file menu as well as the translations

It seems your patch contains some tabs that need to be converted to spaces. Please correct this in all chunks.

>+		<key id="saveandclose-key"
>+			 modifiers="accel"
>+			 key="L"
>+			 command="cmd_accept"/>
The "key" needs a l10n string too.


> <!ENTITY  event.menu.item.delete.label                    "Delete…">
It seems your editor/patch programm has saved this file in a different character encoding than UTF-8. Please make sure the file is saved in UTF-8.


r- to get a new patch, I'll quickly r+ it afterwards.

Thanks for looking into this!
Attachment #406069 - Flags: review?(philipp) → review-
v2, addressing the above comments.
Attachment #406069 - Attachment is obsolete: true
Attachment #432850 - Flags: review?(philipp)
Attachment #432850 - Flags: review?(philipp) → review+
Comment on attachment 432850 [details] [diff] [review]
v.2: Adding Save and close to the Event file menu

Looks good, r=philipp
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/e634ac0b29ab>

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2
You need to log in before you can comment on or make changes to this bug.