Last Comment Bug 392749 - SVG Rectangles Rendering Incorrectly
: SVG Rectangles Rendering Incorrectly
Status: RESOLVED DUPLICATE of bug 315383
:
Product: Core
Classification: Components
Component: SVG (show other bugs)
: 1.8 Branch
: x86 Mac OS X
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-18 18:17 PDT by DJ Perl
Modified: 2007-08-21 05:00 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
A series of rectangles. (1.70 KB, image/svg+xml)
2007-08-18 18:19 PDT, DJ Perl
no flags Details

Description DJ Perl 2007-08-18 18:17:37 PDT
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

For rectangles with large heights, the rendering is incorrect.
The height turns negative.


Reproducible: Always

Steps to Reproduce:
1. Save the following text in a .svg file.
2. Open it in Mozilla.
####

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<g id="column" style="opacity: 1; fill: blue; fill-opacity: 1; stroke: black; stroke-opacity: 1">
<rect x="10" y="10" color="#0000FF" width="21" height="1"/>
<rect x="31" y="10" color="#0000FF" width="21" height="21"/>
<rect x="52" y="10" color="#0000FF" width="21" height="210"/>
<rect x="73" y="10" color="#0000FF" width="21" height="1330"/>
<rect x="94" y="10" color="#0000FF" width="21" height="5985"/>
<rect x="115" y="10" color="#0000FF" width="21" height="20349"/>
<rect x="136" y="10" color="#0000FF" width="21" height="54264"/>
<rect x="157" y="10" color="#0000FF" width="21" height="116280"/>
<rect x="178" y="10" color="#0000FF" width="21" height="203490"/>
<rect x="199" y="10" color="#0000FF" width="21" height="293930"/>
<rect x="220" y="10" color="#0000FF" width="21" height="352716"/>

<rect x="241" y="10" color="#0000FF" width="21" height="352716"/>
<rect x="262" y="10" color="#0000FF" width="21" height="293930"/>
<rect x="283" y="10" color="#0000FF" width="21" height="203490"/>
<rect x="304" y="10" color="#0000FF" width="21" height="116280"/>
<rect x="325" y="10" color="#0000FF" width="21" height="54264"/>
<rect x="346" y="10" color="#0000FF" width="21" height="20349"/>
<rect x="367" y="10" color="#0000FF" width="21" height="5985"/>
<rect x="388" y="10" color="#0000FF" width="21" height="1330"/>
<rect x="409" y="10" color="#0000FF" width="21" height="210"/>
<rect x="430" y="10" color="#0000FF" width="21" height="21"/>
<rect x="451" y="10" color="#0000FF" width="21" height="1"/>
</g>
</svg>

Actual Results:  
For rectangles with large heights, the rendering is incorrect.
The height turns negative.


Expected Results:  
Large rectangles should be rendered correctly, and viewable via scrolling.

<?xml version="1.0" standalone="no"?>
<!DOCTYPE svg PUBLIC "-//W3C//DTD SVG 1.1//EN"
"http://www.w3.org/Graphics/SVG/1.1/DTD/svg11.dtd">

<svg width="100%" height="100%" version="1.1"
xmlns="http://www.w3.org/2000/svg">

<g id="column" style="opacity: 1; fill: blue; fill-opacity: 1; stroke: black; stroke-opacity: 1">
<rect x="10" y="10" color="#0000FF" width="21" height="1"/>
<rect x="31" y="10" color="#0000FF" width="21" height="21"/>
<rect x="52" y="10" color="#0000FF" width="21" height="210"/>
<rect x="73" y="10" color="#0000FF" width="21" height="1330"/>
<rect x="94" y="10" color="#0000FF" width="21" height="5985"/>
<rect x="115" y="10" color="#0000FF" width="21" height="20349"/>
<rect x="136" y="10" color="#0000FF" width="21" height="54264"/>
<rect x="157" y="10" color="#0000FF" width="21" height="116280"/>
<rect x="178" y="10" color="#0000FF" width="21" height="203490"/>
<rect x="199" y="10" color="#0000FF" width="21" height="293930"/>
<rect x="220" y="10" color="#0000FF" width="21" height="352716"/>

<rect x="241" y="10" color="#0000FF" width="21" height="352716"/>
<rect x="262" y="10" color="#0000FF" width="21" height="293930"/>
<rect x="283" y="10" color="#0000FF" width="21" height="203490"/>
<rect x="304" y="10" color="#0000FF" width="21" height="116280"/>
<rect x="325" y="10" color="#0000FF" width="21" height="54264"/>
<rect x="346" y="10" color="#0000FF" width="21" height="20349"/>
<rect x="367" y="10" color="#0000FF" width="21" height="5985"/>
<rect x="388" y="10" color="#0000FF" width="21" height="1330"/>
<rect x="409" y="10" color="#0000FF" width="21" height="210"/>
<rect x="430" y="10" color="#0000FF" width="21" height="21"/>
<rect x="451" y="10" color="#0000FF" width="21" height="1"/>
</g>
</svg>
Comment 1 DJ Perl 2007-08-18 18:19:41 PDT
Created attachment 277259 [details]
A series of rectangles.

This .svg file can be used to reproduce the SVG rendering bug.
Comment 2 Robert Longson 2007-08-19 00:56:32 PDT
This is another example of cairo's range limitation and therefore basically a duplicate of bug 315383, c.f. in particular bug 315383 comment 12.

*** This bug has been marked as a duplicate of bug 315383 ***

Note You need to log in before you can comment on or make changes to this bug.