CRASH 0xC0000005: Access Violation. [win32 talkback, nightly]

VERIFIED FIXED in M17

Status

Core Graveyard
Profile: BackEnd
P3
normal
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: timeless, Assigned: racham)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I request that reporters/reviewers READ each of my bugs THOROUGHLY before 
marking them as dupes, I will be using the same syntax for each of a series of 
bugs.

2000051420 win32 talkback [speculative, see bug 39266]
nt4sp6a 1381

stdout directed to dynamic console
stderr directed to dynamic console
Profile Manager : Profile Wizard and Manager activites : Begin
Profile Manager : Command Line Options : Begin
Profile Manager : Command Line Options : End
has multiple monitor apis is 0
WEBSHELL+ = 1
XPCOM! 60cb5323()
NKFILE! 60691534()
NKFILE! 606922ee()
NECKO! 605ea8e7()
RDF! 606c5013()
RDF! 606c50db()
RDF! 606c4f0b()
CHROME! 600d36a4()
CHROME! 600d5cd4()
CHROME! 600d29b9()
CHROME! 600d1c7e()
NECKO! 605ea8e7()
GKWEB! 60a84720()
GKWEB! 60a88f85()
GKWEB! 60a8880b()
GKWEB! 60a85512()
GKWEB! 60a86de3()
APPSHELL! 60046a7a()
APPSHELL! 60045d62()
APPSHELL! 60045c44()
PROFILE! 606a17bd()
PROFILE! 606a161f()
MOZILLA! 00401997()
MOZILLA! 00401676()
MOZILLA! 00402775()
KERNEL32! 77f1b9ea()

This is based on a bug category for launching mozilla from unc's.  
\\129.2.204.205\mozilla is read only.  Mozilla shouldn't have to use Users50 in 
that directory, windows2000 [this bug is against nt4] has a concept of %home% 
[this box has it too, but it's hacked, so ...].

Comment 1

18 years ago
updating component and owner
Assignee: asadotzler → selmer
Component: Browser-General → Profile Manager BackEnd
QA Contact: jelwell → gbush

Comment 2

18 years ago
Putting "crash" in keyword field.
Keywords: crash

Comment 3

18 years ago
timeless@bemail.org, please add information to the bug about how this crash was
caused and any symptoms you saw while it was happening.  Most of the important
information is missing from this stack trace, it would help to have a full stack
from a debug build.

Comment 4

18 years ago
Bhuvan, can you try to get the details on this?
Assignee: selmer → racham
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Reporter)

Comment 5

18 years ago
selmer@netscape.com I can't reasonably build my own debug build.
If you can create a build that has debug bits for all of the mentioned modules [and 
anything else that would be loaded by this point] I will gladly debug on available machines 
[w2k and w98, sorry the nt4 boxes aren't available].

As for the process, I thought I was clear.
running mozilla from unc paths usually crashes mozilla [early, I've never had it run 
normally].
The unc is readonly.  I can change that [and will in future tests].

I will later try running mozilla on linux from readonly but I expect that works fine.

lastly, whois Bhuvan you didn't CC him.

Updated

18 years ago
Blocks: 41057
Summary: TimelessUnique CRASH 0xC0000005: Access Violation. [win32 talkback, nightly] → CRASH 0xC0000005: Access Violation. [win32 talkback, nightly]

Comment 6

18 years ago
Bug 6464 is related (if not the same).

Comment 7

18 years ago
The meta bug got [nsbeta2+].
(Assignee)

Comment 8

18 years ago
Let us see what we can do in beta3 for this...

Adding nsbeta3 keyword.
Keywords: nsbeta3

Comment 9

18 years ago
39289 seems to be about the same crash.  6464 is the bug about home directories.  
This bug must be a dup of one of those unless you're claiming you know the crash 
differs from 39289 somehow.  Please close dup or clarify how this crash differs 
from the one in 39289.
(Reporter)

Comment 10

18 years ago
This one is for -ProfileWizard
That one is for -CreateProfile
It's quite possible they crash in the same fashion for the same reasons. But 
they are different.  Profile Wizard should be able to run and let me create a 
profile somewhere near d:\temp\users50 and -CreateProfile should be able to do 
this from a command line.  
As for 6464, I don't care.  The two command lines I use should work 
independently of any silly default location of Users50. Therefore I don't 
believe this is a dupe of that.

racham@netscape.com says the fix for my two bugs will be along the same lines. 
That may be correct, so when they are both fixed they can both be marked as 
such. I think it might be possible for one to be fixed without fixing the other 
[I'm not encouraging this].

racham, thanks for working on this.
(Assignee)

Comment 11

18 years ago
timeless,

Are you still getting this...?

We got rid of CreateProfile one last week. So, please let me know about this 
one. This we are not able to reproduce.
(Reporter)

Comment 12

18 years ago
(QFA)Talkback error: Can't Initialize.
Resolving as fixed, I'll try to find a new bug for talkback (I can use filemon 
to find out what it was doing if people care)
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

18 years ago
Erm oh yeah, quiting crashes (windows wants to make an event log entry but 
that's full, so i'll need to do something about that)
(Reporter)

Comment 14

18 years ago
Created attachment 13458 [details]
Mozilla [2000082208] ProfileWizard w2k event log [zipped]

Comment 15

18 years ago
verified build 2000082508
Status: RESOLVED → VERIFIED
No longer blocks: 41057
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.