Do not send hello extensions when using SSL v3.0

RESOLVED FIXED in 3.11.8

Status

NSS
Libraries
P2
normal
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: kaie, Assigned: Nelson Bolyard (seldom reads bugmail))

Tracking

3.11.7
3.11.8

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
In order to fix an issue with Thunderbird and the matrixssl library, it has been proposed to never send hello extensions when using SSL v3.0

See bug 368611 and the discussions around the report from Filippo.
(Reporter)

Updated

10 years ago
Blocks: 368611
(Assignee)

Comment 1

10 years ago
Created attachment 277361 [details] [diff] [review]
tested patch v1

Kai, Does this patch solve the problem?
Assignee: nobody → nelson
Status: NEW → ASSIGNED
Attachment #277361 - Flags: review?
(Reporter)

Comment 2

10 years ago
Comment on attachment 277361 [details] [diff] [review]
tested patch v1

This patch works great!

r=kengert
Attachment #277361 - Attachment description: untested patch v1 → tested patch v1
Attachment #277361 - Flags: review? → review+
(Reporter)

Comment 3

10 years ago
Setting bug to 3.11.x branch, it would be good to get this patch on that branch and include it the next time the stable Thunderbird/Firefox 2.x branches pick up a newer NSS release.
Version: trunk → 3.11.7
(Reporter)

Comment 4

10 years ago
Comment on attachment 277361 [details] [diff] [review]
tested patch v1

Who should do the second review for 3.11.x?
Attachment #277361 - Flags: review?
(Assignee)

Comment 5

10 years ago
Comment on attachment 277361 [details] [diff] [review]
tested patch v1

I'll ask Julien for a second review on this one-line patch.
Attachment #277361 - Flags: review? → review?(julien.pierre.boogz)
(Assignee)

Comment 6

10 years ago
On trunk:
Checking in ssl3con.c; new revision: 1.103; previous revision: 1.102
Priority: -- → P2
Target Milestone: --- → 3.11.8

Updated

10 years ago
Attachment #277361 - Flags: review?(julien.pierre.boogz) → review+
(Reporter)

Comment 7

10 years ago
This needs to get checked in on NSS 3.11.x branch. Let me know if I should do it.
(Assignee)

Comment 8

10 years ago
On branch:
Checking in ssl3con.c; new revision: 1.76.2.21; previous revision: 1.76.2.20
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Duplicate of this bug: 368611
Duplicate of this bug: 374058
You need to log in before you can comment on or make changes to this bug.