All users were logged out of Bugzilla on October 13th, 2018

Applying text-align: justify to Asian scripts causes combining characters to display separately from base characters

RESOLVED DUPLICATE of bug 240914

Status

()

--
major
RESOLVED DUPLICATE of bug 240914
11 years ago
11 years ago

People

(Reporter: ishida, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6

Applying text-align:justify to Asian scripts causes combining characters to display separately from their base characters.  Graphic examples can be found at http://people.w3.org/rishida/blog/?p=111  The text from the examples can be found at http://people.w3.org/rishida/articles/phrases

Effectively, this prevents the use of the CSS text-align:justify for South Asian users.

Note that Thai and Myanmar seem unaffected by this, as do other scripts with combining characters such as Vietnamese (see http://www.w3.org/International/questions/qa-css-charset.vi.php).

Reproducible: Always

Steps to Reproduce:
1. go to http://people.w3.org/rishida/articles/phrases
2. edit the css to :lang(hi) { ... text-align:justify; } etc
3. look at the displayed text
Actual Results:  
See above

Expected Results:  
See above

Note that I have heard from Asian developers on several occasions that this is problematic, though none of them seem to have raised a bug as far as I can tell.

I would class this as a major broken feature for people from the affected region.

Comment 1

11 years ago
This is fixed for Firefox 3. A build from http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/ should work.

Comment 2

11 years ago
Created attachment 277561 [details]
Trunk screen shot of the Multiscript phrases

Comment 3

11 years ago
Finally found the bug that fixed this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 240914
You need to log in before you can comment on or make changes to this bug.