event recurrence disappears on remote calender reload

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Rien.Timmer1947, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.4pre) Gecko/20070614 Sunbird/0.5

When I create a recurring event with Sunbird in a remote calendar it appears to work fine, but on the first reload of the remote calendar the initial event remains but all recurrences disappear. A recurrent event in a local calendar works fine.
When I create the recurring event in the remote calendar with Google calendar Sunbird sees the event and all recurrences correctly.

Reproducible: Always

Steps to Reproduce:
1. Create recurrent event in remote calendar
2. Reload remote calendars
3.
Actual Results:  
Recurrences disappear.

Expected Results:  
Leave the recurrences in place.
Are you using a Google Calendar with the Provider for Google Calendar? In that case, note that recurring events are internally shown as single events due to bug 362650 not being fixed.

I was not able to reproduce with my webdav setup. Please answer the following questions:
* Have you tried this with the latest nightly?
* What type of remote calendar are you using?
* What type of server is running remotely?
* If using apache/webdav what does your configuration look like?
(Reporter)

Comment 2

11 years ago
I'm using the PortableApps version of Sunbird 0.5.
All my remote calendars were originally set up with Google Calendar.
So the remote server is Google?
Does that make them webdav?

I used the procedure on gcaldaemon to connect the remote calendars to Sunbird, (http://gcaldaemon.sourceforge.net/usage.html#top) replacing www.google.com by localhost:9090 in the url for the calendar and running gcaldaemon.

On my system it's 100% reproducible.
Google Calendar didn't support recurring events. It does now in version 0.4, together with sunbird 0.8 (or respective later pre versions).

This issue shouldn't show up anymore, please reopen if it does.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.