Custom Fields should allow dropdown user-select option for a defined group

NEW
Assigned to

Status

()

Bugzilla
Administration
P3
enhancement
11 years ago
5 years ago

People

(Reporter: miketosh, Assigned: miketosh)

Tracking

(Depends on: 1 bug)

Dependency tree / graph

Details

(Assignee)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.6) Gecko/20070725 Firefox/2.0.0.6
Build Identifier: Bugzilla 3.0

In the flag definitions, there should be an option to make the requestee field a drop down of all members of the grant group.  For most smaller installations this makes good sense.

If the flag is not specifically requestable, this goes out the window, but that is not the case everywhere.





Reproducible: Always

Steps to Reproduce:
1. Define a flag as specifically requestable, and configure grant group to a limited user group
2. Go to a random issue that falls under that flags scope, and set the flag status to '?'
3. Enter a non-member of the grant group in the requestee field.
Actual Results:  
Get an error:
<user x> does not have permission to set the <flag y> flag. Please select a user who is a member of the <group z> group.

OR get this other error:
Bugzilla was unable to make any match at all for one or more of the names and/or email addresses you entered on the previous page.
Please go back and try other names or email addresses.
<flag y> requestee: <string x> did not match anything 

Expected Results:  
I would like to have a checkbox in the editflagtypes.cgi below the "Grant Group" dropdown:
[]Provide users a dropdown list of members of this Grant Group to choose from

(CAUTION, NIT HERE:  And why is it called the grant group if they are the requestees?  Shouldn't it be the grantor?  or the requestable group?  And what about setter vs request group/requestor?  If they reference the same side of the flag operation, they should be named similar things.  Ok, off the soapbox.  Great product, and I don't want to upset anyone.)
(Assignee)

Comment 1

11 years ago
This would also be a great addition to the Custom Field definitions.  We use several "Verifier" fields, where we have a specific group of people from which a subset of them go in and verify the issue is resolved.

To enable a group-membership dropdown of users and inherited users (not just direct group members) would certainly provide a huge enhancement to the custom field area.
Version: unspecified → 3.0

Updated

11 years ago
Assignee: create-and-change → attach-and-request
Component: Creating/Changing Bugs → Attachments & Requests
Whiteboard: DUPME

Comment 2

11 years ago
This feature exists in Bugzilla 3.1.1, which we released yesterday.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPME
Duplicate of bug: 339437
(Assignee)

Comment 3

11 years ago
How about this functionality for custom fields?

Much easier once the functionality is incorporated for flags, but i guess it is much less important.  

Still a nice enhancement.
Status: RESOLVED → UNCONFIRMED
Component: Attachments & Requests → Administration
Resolution: DUPLICATE → ---
Summary: Flag definitions should allow dropdown select for GRANT group when specifically requestable → Custom Fields should allow dropdown user-select option for a defined group

Comment 4

11 years ago
Very close from bug 287332, except that bug doesn't restrict users to a specific group.
Blocks: 91037
Depends on: 287332

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3
(Assignee)

Comment 5

10 years ago
Also, users should be CC'd, or this should add a new column in the email preference page.

Updated

8 years ago
Assignee: attach-and-request → michael.j.tosh
You need to log in before you can comment on or make changes to this bug.