Last Comment Bug 393477 - Hardcode language pack minVersion on the stable branch
: Hardcode language pack minVersion on the stable branch
Status: VERIFIED FIXED
: verified1.8.1.8
Product: Core
Classification: Components
Component: Localization (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-23 17:15 PDT by Axel Hecht [:Pike]
Modified: 2007-10-08 04:18 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
hardcode minVersion in browser-mail/locales/generic/install.rdf (1.37 KB, patch)
2007-08-23 17:15 PDT, Axel Hecht [:Pike]
benjamin: review+
dveditz: approval1.8.1.8+
Details | Diff | Review

Description Axel Hecht [:Pike] 2007-08-23 17:15:36 PDT
Created attachment 277976 [details] [diff] [review]
hardcode minVersion in browser-mail/locales/generic/install.rdf

On the stable branch, we should hardcode the minVersion of language packs, it makes using the branch for agile development of new localizations much more attractive. Plus, it's a dead simple and safe thing to do, as we know the minVersion anyway. For Firefox, I'm using 2.0.0.4 due to the change in the migration wizard, which should be good enough, for Thunderbird, I'm using 2.0 proper.

Without this fix, the minVersion gets set to 2.0.0.7pre, which makes it untestable on the latest release bits. That's just not right.

This patch is branch only.

Requesting review from Benjamin for l10n repack foo, CCing mconnor and mscott to give them a chance to veto this from a application point of view.
Comment 1 Axel Hecht [:Pike] 2007-08-30 10:54:44 PDT
Comment on attachment 277976 [details] [diff] [review]
hardcode minVersion in browser-mail/locales/generic/install.rdf

Requesting branch approval. This is only affecting language packs generated from the stable branch, and sets the minVersion to something that's reasonable.

If we'd have to break compat down the 2.0.0.x stream, we'll adjust these again.
Comment 2 Daniel Veditz [:dveditz] 2007-09-07 11:53:29 PDT
Comment on attachment 277976 [details] [diff] [review]
hardcode minVersion in browser-mail/locales/generic/install.rdf

approved for 1.8.1.7, a=dveditz for release-drivers
Comment 3 Axel Hecht [:Pike] 2007-09-07 15:40:28 PDT
Landed on branch.
Comment 4 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-10-04 15:08:55 PDT
I guess there is no way to verify this on the branch, right?
Comment 5 Axel Hecht [:Pike] 2007-10-08 04:18:21 PDT
The .8pre language packs on http://l10n.mozilla.org/~buildslave/incubator/ work on stable releases, so this is verified.

Note You need to log in before you can comment on or make changes to this bug.