Closed Bug 393490 Opened 13 years ago Closed 13 years ago

Text overlapping image in complicated float situation

Categories

(Core :: Layout: Floats, defect, P2)

x86
Windows XP
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Assigned: roc)

References

()

Details

(Keywords: regression, testcase)

Attachments

(3 files)

Attached file testcase
See testcase, the text should not overlap the green block, but it does in current trunk build.

With the url, I sometimes see this happening on first load/shift-reload with the heading overlapping the image.

This regressed between 2006-12-07 and 2006-12-08, regression from bug 300030.
Blocks: 413510
Flags: blocking1.9?
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → NEW
Attached patch fixSplinter Review
This turned out to be a lot simpler than I feared. It's a very simple bug in nsIntervalSet::IncludeInterval. Basically we have one interval already, let's say [100,200] and we add an overlapping interval, say [150,250] ... the new interval gets put in the front of the list, then it subsumes the old interval, and the current code just updates the endpoint of the new interval instead of doing a full union.
Assignee: nobody → roc
Status: NEW → ASSIGNED
Attachment #304659 - Flags: superreview?(dbaron)
Attachment #304659 - Flags: review?(dbaron)
Whiteboard: [needs review]
Comment on attachment 304659 [details] [diff] [review]
fix

Er, yikes.  How'd I manage that?
Attachment #304659 - Flags: superreview?(dbaron)
Attachment #304659 - Flags: superreview+
Attachment #304659 - Flags: review?(dbaron)
Attachment #304659 - Flags: review+
(Believe it or not, this is the first substantive change to the file since I landed the initial version over six years ago.  Not sure how this slipped through that long...)
Whiteboard: [needs review] → [needs landing]
checked in with reftest
Status: ASSIGNED → RESOLVED
Closed: 13 years ago13 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [needs landing]
You need to log in before you can comment on or make changes to this bug.