Collapse header view and re-opening it (headerpane) kills twisty at To:-field

RESOLVED FIXED

Status

RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: jiha.bugzilla, Unassigned)

Tracking

({regression})

Trunk
x86
Linux
regression
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007082317 Mnenhy/0.7.5.20003 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007082317 SeaMonkey/2.0a1pre

Using the twisty at the Subject:-field at the headerpane to collapse and reopening it again makes the twisty in front of the To:-field disappearing.

Reproducible: Always

Steps to Reproduce:
1. You need a message with many email recipients in the To: so there is a twisty present in front of the To: at the headerpane.
2. Switch to collapsed view by clicking the twisty in front of the Subject:-field at the headerpane. 
3. Switch to the detailed view again by clicking the twisty in front of the Subject:-field again.
Actual Results:  
The twisty in front of the To:-field is gone.

Expected Results:  
The twisty in front of the To:-field should be still present as it was.

If the headerpane is already collapsed at the startup, the twisty at the To:-field will be shown the first time when reopening the headerpane. Collapsing and reopening again will kill the twisty.


I tested without mnenhy (!) with:
-- Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007082317 SeaMonkey/2.0a1pre (self compiled from cvs) -> Twisty killed
-- 2007082405_thunderbird-2.0.0.7pre.en-US.linux-i686 (official trunk nightly) -> Twisty killed
-- 2007082403_thunderbird-3.0a1pre.en-US.linux-i686 (official trunk nightly) -> Twisty killed
-- TB version 1.5.0.12 (20060911) (official SUSE version)  -> Twisty *not* killed

I enabled Mnenhy in the official SUSE TB version 1.5.0.12 (20060911) from above and the twisty *gets* killed.

I guess all this has something to do with Bug 62033 which brought the feature of references links to the headerpane. Mnenhy also does this.
(Reporter)

Comment 1

11 years ago
(In reply to comment #0)

> I tested without mnenhy (!) with:
> -- Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007082317
> SeaMonkey/2.0a1pre (self compiled from cvs) -> Twisty killed
> -- 2007082405_thunderbird-2.0.0.7pre.en-US.linux-i686 (official trunk nightly)
> -> Twisty killed

Sorry, typo here ^^^ 
Twisty gets *not* killed on 2007082405_thunderbird-2.0.0.7pre.en-US.linux-i686 (official trunk nightly)

> -- 2007082403_thunderbird-3.0a1pre.en-US.linux-i686 (official trunk nightly) ->
> Twisty killed
> -- TB version 1.5.0.12 (20060911) (official SUSE version)  -> Twisty *not*
> killed
> 
> I enabled Mnenhy in the official SUSE TB version 1.5.0.12 (20060911) from above
> and the twisty *gets* killed.
> 
> I guess all this has something to do with Bug 62033 which brought the feature
> of references links to the headerpane. Mnenhy also does this.
> 

(Reporter)

Updated

11 years ago
Blocks: 393583

Comment 2

11 years ago
This regressed between linux seamonkey build 2006-12-19-08-trunk and 2006-12-20-08-trunk (so older than 62033)
Keywords: regression
Version: unspecified → Trunk

Comment 3

11 years ago
It seems bug 363933 is what broke this
Blocks: 363933

Comment 4

11 years ago
Created attachment 278209 [details] [diff] [review]
Ignore horizontal overflow
Attachment #278209 - Flags: review?(mscott)

Comment 5

11 years ago
What's happening now is that somehow that when the entire pane is collapsed the To: field is treated has overflowing horizontally. When you then uncollapsed it bug 363933 then causes a horizontal underflow event to get dispatched, at which point the old code erroneously hides the twisty. Note that event.detail could be 2 to indicate both horizontal and vertical underflow, which might apply in the case when the entire pane is uncollapsed when the To: field isn't overflowing.

Comment 6

11 years ago
Comment on attachment 278209 [details] [diff] [review]
Ignore horizontal overflow

you rock Neil.
Attachment #278209 - Flags: review?(mscott) → review+

Comment 7

11 years ago
Fix checked in.

(In reply to comment #6)
>(From update of attachment 278209 [details] [diff] [review])
>you rock Neil.
Only because ajschult determined the check in that that exposed the bug.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Duplicate of this bug: 393583
You need to log in before you can comment on or make changes to this bug.