Closed Bug 393596 Opened 17 years ago Closed 17 years ago

JavaScript strict warnings in sun-calendar-event-dialog-attendees.xml

Categories

(Calendar :: General, defect)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: ssitter)

Details

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.7pre) Gecko/20070824 Sunbird/0.7pre

JavaScript strict warnings in sun-calendar-event-dialog-attendees.xml

Steps to Reproduce:
1. Enable strict warnings
2. Create new event. In the event dialog select Options -> Invite Attendees
3. Check Console

Warning: function set_force24Hours does not always return a value
Source File: chrome://calendar/content/sun-calendar-event-dialog-attendees.xml
Line: 2082, Column: 20
Source Code:
              return;

Warning: function set_force24Hours does not always return a value
Source File: chrome://calendar/content/sun-calendar-event-dialog-attendees.xml
Line: 2091, Column: 20
Source Code:
          return val;
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #278186 - Flags: review?(michael.buettner)
Comment on attachment 278186 [details] [diff] [review]
rev0 - fix warning

Taking over review since mickey is on vacation. Looks good, r=philipp
Attachment #278186 - Flags: review?(michael.buettner) → review+
Keywords: checkin-needed
Checked in on HEAD and MOZILLA_1_8_BRANCH by Philipp.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 0.7
VERIFIED with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070828 Calendar/0.7pre.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: