Matching name for document.all doesn't reflect IE in all cases

RESOLVED FIXED

Status

()

Core
DOM
P1
normal
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Martijn Wargers (zombie), Assigned: sicking)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
wanted1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
Created attachment 278135 [details]
testcase

I originally mentioned this in bug 259332, comment 12.

There was Hendrix feedback that some search doesn't work:
http://groups.google.com/group/mozilla.feedback/browse_thread/thread/2b001eb03ecd2f17/7c5cbbdb9c658c0c?lnk=st
I tracked this down as a regression from bug 259332.
Mozilla used to allow to find <select> elements by name using the document.all function. Now that doesn't work anymore.

Jonas asked in bug 259332, comment 13 on what elements in IE allow name-matching using document.all. This is what the testcase is about.

I get as result in IE:
APPLET
A
EMBED
FORM
IFRAME
IMG
INPUT
OBJECT
TEXTAREA
SELECT
MAP
META
BUTTON

Updated

10 years ago
Duplicate of this bug: 423360
Flags: wanted-next+
(Reporter)

Updated

10 years ago
Blocks: 279919

Updated

10 years ago
Duplicate of this bug: 433705

Updated

10 years ago
Blocks: 259332

Updated

10 years ago
Keywords: regression
Assignee: nobody → jonas
Flags: wanted1.9.1+
Flags: wanted1.9.0.x?
Flags: wanted-next+
Priority: -- → P1
Jonas, any update here?
Flags: wanted1.9.0.x? → wanted1.9.0.x+
This was fixed as part of the patch in bug 436094
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Depends on: 436094
Resolution: --- → FIXED
Flags: wanted1.9.0.x+
You need to log in before you can comment on or make changes to this bug.