Enable async reflow processing during document load

VERIFIED FIXED in M18

Status

()

P2
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: nisheeth_mozilla, Assigned: nisheeth_mozilla)

Tracking

({perf})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][PDTP2])

(Assignee)

Description

19 years ago
The following things need to happen in layout:

1) Differentiate between reflow events generated during document load and after 
document load.
2) Create an object that exposes the nsIRequest interface.  Add the object to 
the load group at the start of layout and remove it once all the "during doc 
load" reflow events have been processed.
3) Fix up the perf metrics code.

The following things need to happen in necko:
1) Change nsILoadGroup so that requests can get added and removed rather than 
channels.
2) Fix up the XUL cache code.

We'll work on this post beta 2.
(Assignee)

Comment 1

19 years ago
Accepting bug and setting target milestone to M17...
Status: NEW → ASSIGNED
Target Milestone: --- → M17
(Assignee)

Comment 2

19 years ago
*** Bug 24822 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
Shouldn't this be for *all* OS ?
(Assignee)

Comment 4

19 years ago
Changing OS to All and marking nsbeta3...
Keywords: nsbeta3
OS: Windows NT → All
Marking perf.
Keywords: perf

Comment 6

19 years ago
nsbeta3+, to the extent that it will increased perceived speed/responsiveness, 
especially on Mac.
Whiteboard: [nsbeta3+]
Target Milestone: M17 → M18
(Assignee)

Comment 7

18 years ago
Marking P1..
Priority: P3 → P1

Updated

18 years ago
Priority: P1 → P2
Whiteboard: [nsbeta3+] → [nsbeta3+][PDTP2]

Comment 8

18 years ago
PDT downgrading to P2 and adding [PDTP2] to status whiteboard. We'd really like
to have this.

Comment 9

18 years ago
PDT wondering if this is the same bug as blocking the throbber/progress while
downloading a page. Still agree P2.
(Assignee)

Comment 10

18 years ago
I have this fixed and will check it in tonight protected by a pref that is
disabled by default.  I'm not enabling the pref by default because I did not see
much difference in perceived performance on my windows box.  Mike and I will 
test
this on the Mac on (slow machine, slow network), (slow machine, fast network),
(fast machine, slow network), (fast machine, fast network) configurations.  If
this makes a significant difference in any configuration, we can enable the pref
by default.  Right now, the only data point we have is that this fix does not do
much on a fast machine, fast network configuration on Windows.
Whiteboard: [nsbeta3+][PDTP2] → [nsbeta3+][PDTP2][Have fix, need testing]
(Assignee)

Comment 11

18 years ago
*** Bug 50634 has been marked as a duplicate of this bug. ***
Keywords: nsmac1
(Assignee)

Comment 12

18 years ago
I've turned on async reflow during doc load by default. It can be turned off by
setting the "layout.reflow.async.duringDocLoad" pref to false in prefs.js.

Marking bug fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [nsbeta3+][PDTP2][Have fix, need testing] → [nsbeta3+][PDTP2]

Comment 13

18 years ago
Marking verified per last comments.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.