Last Comment Bug 393922 - Remove nsIDownloadProgressListener::onStatusChange and nsIDownloadProgressListener::onLocationChange
: Remove nsIDownloadProgressListener::onStatusChange and nsIDownloadProgressLis...
Status: RESOLVED FIXED
[good first bug]
:
Product: Toolkit
Classification: Components
Component: Download Manager (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9beta3
Assigned To: Graeme McCutcheon [:graememcc]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-27 16:25 PDT by Shawn Wilsher :sdwilsh
Modified: 2008-07-31 04:30 PDT (History)
4 users (show)
sdwilsh: in‑testsuite-
sdwilsh: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v0.1 (2.60 KB, patch)
2007-12-27 15:36 PST, Graeme McCutcheon [:graememcc]
sdwilsh: review-
Details | Diff | Splinter Review
v0.2 (8.47 KB, patch)
2007-12-28 03:58 PST, Graeme McCutcheon [:graememcc]
sdwilsh: review+
mbeltzner: approval1.9+
Details | Diff | Splinter Review

Description Shawn Wilsher :sdwilsh 2007-08-27 16:25:53 PDT
Spun off from Bug 289540 Comment 21.  These are unused and should be removed.
Comment 1 Graeme McCutcheon [:graememcc] 2007-12-27 15:36:32 PST
Created attachment 294698 [details] [diff] [review]
v0.1
Comment 2 Shawn Wilsher :sdwilsh 2007-12-27 16:30:09 PST
Comment on attachment 294698 [details] [diff] [review]
v0.1

Almost!  You need to generate a new uuid for the interface since methods are being removed (http://developer.mozilla.org/en/docs/Generating_GUIDs).

Also, there are some test files that need the extra methods removed:
http://tinyurl.com/2nmvlq
Comment 3 Graeme McCutcheon [:graememcc] 2007-12-28 03:58:45 PST
Created attachment 294726 [details] [diff] [review]
v0.2

Changes as per comment 2
Comment 4 Shawn Wilsher :sdwilsh 2007-12-28 06:44:56 PST
Comment on attachment 294726 [details] [diff] [review]
v0.2

r=sdwilsh
Comment 5 Mike Beltzner [:beltzner, not reading bugmail] 2007-12-28 07:50:36 PST
Comment on attachment 294726 [details] [diff] [review]
v0.2

a=beltzner for 1.9
Comment 6 Shawn Wilsher :sdwilsh 2007-12-28 09:15:56 PST
Thanks for the patch!
Comment 7 Reed Loden [:reed] (use needinfo?) 2007-12-28 19:19:00 PST
Thanks for the patch!

Checking in toolkit/components/downloads/public/nsIDownloadProgressListener.idl;
/cvsroot/mozilla/toolkit/components/downloads/public/nsIDownloadProgressListener.idl,v  <--  nsIDownloadProgressListener.idl
new revision: 1.6; previous revision: 1.5
done
Checking in toolkit/components/downloads/test/unit/head_download_manager.js;
/cvsroot/mozilla/toolkit/components/downloads/test/unit/head_download_manager.js,v  <--  head_download_manager.js
new revision: 1.8; previous revision: 1.7
done
Checking in toolkit/components/downloads/test/unit/test_bug_395092.js;
/cvsroot/mozilla/toolkit/components/downloads/test/unit/test_bug_395092.js,v  <--  test_bug_395092.js
new revision: 1.2; previous revision: 1.1
done
Checking in toolkit/components/downloads/test/unit/test_bug_401430.js;
/cvsroot/mozilla/toolkit/components/downloads/test/unit/test_bug_401430.js,v  <--  test_bug_401430.js
new revision: 1.2; previous revision: 1.1
done
Checking in toolkit/components/downloads/test/unit/test_download_manager.js;
/cvsroot/mozilla/toolkit/components/downloads/test/unit/test_download_manager.js,v  <--  test_download_manager.js
new revision: 1.15; previous revision: 1.14
done
Checking in toolkit/components/downloads/test/unit/test_resume.js;
/cvsroot/mozilla/toolkit/components/downloads/test/unit/test_resume.js,v  <--  test_resume.js
new revision: 1.3; previous revision: 1.2
done
Checking in toolkit/mozapps/downloads/content/DownloadProgressListener.js;
/cvsroot/mozilla/toolkit/mozapps/downloads/content/DownloadProgressListener.js,v  <--  DownloadProgressListener.js
new revision: 1.36; previous revision: 1.35
done

Note You need to log in before you can comment on or make changes to this bug.