Closed Bug 393959 Opened 12 years ago Closed 12 years ago

upgrade to sqlite 3.4.2

Categories

(Toolkit :: Storage, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX
mozilla1.9beta1

People

(Reporter: moco, Assigned: sdwilsh)

References

()

Details

Attachments

(1 file)

upgrade to sqlite 3.4.2?

We've currently got 3.4.1 (http://lxr.mozilla.org/seamonkey/source/db/sqlite3/README.MOZILLA)

According to http://www.sqlite.org/changes.html, 3.4.2 just came out.

Note, I don't see any pressing reasons to upgrade in the notes (below) so we might wait until a future release.

shawn, what do you think?

2007 August 13 (3.4.2)

Fix a database corruption bug that might occur if a ROLLBACK command is executed in auto-vacuum mode and a very small soft_heap_limit is set. Ticket #2565. 
Add the ability to run a full regression test with a small soft_heap_limit. 
Fix other minor problems with using small soft heap limits. 
Work-around for GCC bug 32575. 
Improved error detection of misused aggregate functions. 
Improvements to the amalgamation generator script so that all symbols are prefixed with either SQLITE_PRIVATE or SQLITE_API.
At first glance, the last point could be usefull, and could shrink our library size and improve performance.
Attached patch v1.0Splinter Review
We may want to file a follow-up bug about defining the SQLITE* things to what we want for exporting purposes.
Assignee: nobody → comrade693+bmo
Status: NEW → ASSIGNED
Attachment #279240 - Flags: review?(sspitzer)
Target Milestone: --- → mozilla1.9 M9
shawn, this came up at the fx 3 meeting today.

I'm not convinced the rewards ("shrink our library size and improve performance") out weigh risk here.

Do you have any numbers on the size or performance gains?  

I'm thinking we should hold off on the upgrade to 3.4.2 for now.
(In reply to comment #4)
> shawn, this came up at the fx 3 meeting today.
> 
> I'm not convinced the rewards ("shrink our library size and improve
> performance") out weigh risk here.
> 
> Do you have any numbers on the size or performance gains?  
> 
> I'm thinking we should hold off on the upgrade to 3.4.2 for now.
I don't really think there is much risk at all involved.  We have a really good set of unit tests that have caught things in the past, and say nothing is wrong here.  The possible upgrade to 3.5 is certainly much riskier.
per Gecko Meeting today, we can take this.  I think people just got confused with my post about SQLite 3.5 (and it being in alpha).  Seth, can you go ahead and review this?  (there are no changes for us, just sqlite changes).
Comment on attachment 279240 [details] [diff] [review]
v1.0

r=sspitzer, but as far as landing this in late m8 or early m9, I'm leaning towards earrly m9, because I think the perf wins don't outweigh risk for m8.

shawn, what is your opinion?
Attachment #279240 - Flags: review?(sspitzer) → review+
As per Gecko meeting, early M9
Attachment #279240 - Flags: approval1.9?
Summary: upgrade to sqlite 3.4.2? → upgrade to sqlite 3.4.2
Attachment #279240 - Flags: approval1.9? → approval1.9+
Checking in db/sqlite3/README.MOZILLA;
/cvsroot/mozilla/db/sqlite3/README.MOZILLA,v  <--  README.MOZILLA
new revision: 1.13; previous revision: 1.12
done
Checking in db/sqlite3/src/sqlite3.c;
/cvsroot/mozilla/db/sqlite3/src/sqlite3.c,v  <--  sqlite3.c
new revision: 1.7; previous revision: 1.6
done
Checking in db/sqlite3/src/sqlite3.h;
/cvsroot/mozilla/db/sqlite3/src/sqlite3.h,v  <--  sqlite3.h
new revision: 1.12; previous revision: 1.11
done
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
This blew up on Windows and Linux; backed out.

dmose:  /builds/slave/trunk_centos5/mozilla/db/sqlite3/src/sqlite3.c:9310: error: array size missing in "sqlite3OpcodeNames"

was one of several error messages.  luser speculates that compiling with warnings as errors may be part of what's hurting us here.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Silly nitpick on README.MOZILLA:

s/They you need to update sqlite3file.h/Then you need to update sqlite3file.h/
I'm inclined to WONTFIX based on those errors - maybe we can try the next one...
3.5 alpha is out. Usually I wouldn't mention alphas but since cairo HEAD was merged I thought someone might want to take a look.
http://www.sqlite.org/34to35.html
SQLite 3.5 will require much more work, and I'm not sure yet if we want to take it for 1.9.

Resolving WONTFIX because we don't want to patch sqlite to get our code working.  If they come out with a 3.4.3 we can try and take that since it seems that other people have complained about this compiler errors as well.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → WONTFIX
do we have a bug about upgrading to 3.5.x?
No, we do not.
> No, we do not.

Any objection to me re-opening this bug and morphing it to "upgrade to the latest sqlite"?

I don't think it is going to happen for 1.9 either, but we should keep track of this issue.
I'd say lets just open a new bug.
> I'd say lets just open a new bug.

see bug #406087, thanks shawn.
You need to log in before you can comment on or make changes to this bug.