Closed Bug 393982 Opened 12 years ago Closed 12 years ago

Download Manager does not appear when saving files

Categories

(Toolkit :: Downloads API, defect, major)

x86
Windows Vista
defect
Not set
major

Tracking

()

VERIFIED FIXED
mozilla1.9alpha8

People

(Reporter: jmjjeffery, Assigned: mossop)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007082705 Minefield/3.0a8pre Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007082705 Minefield/3.0a8pre Firefox/3.0

I am unable to download files. I have the action set to 'ask me where to save'.

Right-click and use 'Save link as...'
Select your download location and click 'Save'
The Download Manager never appears and when you open the DM, you see at the bottom of the list 'Starting' but nothing is transferring.

When trying to close the browser, I see a warning box about 'Cancel x number of downloads'

This has regressed between: 
2007082705 and 2007082718 (hour 14 build)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Actual Results:  
Download Manager not showing, and download is not happening.

Expected Results:  
Download Manager appears and the download progresses.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a8pre) Gecko/2007082705 Minefield/3.0a8pre Firefox/3.0 ID:2007082705

Same in Safe-Mode
Keywords: regression
Version: unspecified → Trunk
This error is kicked in the JS Console when starting the download:

Error: Component returned failure code: 0x80040154 (NS_ERROR_FACTORY_NOT_REGISTERED) [nsITransfer.init]
Source file: chrome://global/content/contentAreaUtils.js
Line: 323
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007082803 Minefield/3.0a8pre ID:2007082803
I see the same
Status: UNCONFIRMED → NEW
Ever confirmed: true
works: 20070827_1656_firefox-3.0a8pre.en-US.win32
broken: 20070827_1712_firefox-3.0a8pre.en-US.win32

http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=1188258960&maxdate=1188259919

According to the checkin comment, this is due to bug 398982, but since that bug doesn't exist, i will guess it really meant bug 389982 ;)
Blocks: 389982
THe new js component introduced isn't getting packaged. Patch on the way.
Assignee: nobody → dtownsend
Attachment #278574 - Flags: review?
Attachment #278574 - Flags: review? → review?(comrade693+bmo)
Attachment #278574 - Flags: review?(comrade693+bmo) → review+
Checking in browser/installer/unix/packages-static;
/cvsroot/mozilla/browser/installer/unix/packages-static,v  <--  packages-static
new revision: 1.132; previous revision: 1.131
done
Checking in browser/installer/windows/packages-static;
/cvsroot/mozilla/browser/installer/windows/packages-static,v  <--  packages-static
new revision: 1.140; previous revision: 1.139
done
Checking in mail/installer/windows/packages-static;
/cvsroot/mozilla/mail/installer/windows/packages-static,v  <--  packages-static
new revision: 1.76; previous revision: 1.75
done
Checking in calendar/installer/windows/packages-static;
/cvsroot/mozilla/calendar/installer/windows/packages-static,v  <--  packages-static
new revision: 1.47; previous revision: 1.46
done
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Stupid installer manifests...

Sorry about that!
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a8pre) Gecko/2007082807 Minefield/3.0a8pre ID:2007082807
VERIFIED
Status: RESOLVED → VERIFIED
Target Milestone: --- → Firefox 3 M8
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.