Last Comment Bug 394120 - "ASSERTION: post-reflow queues not empty" with xul:listboxbody and xul:text
: "ASSERTION: post-reflow queues not empty" with xul:listboxbody and xul:text
Status: RESOLVED FIXED
: assertion, fixed1.8.1.8, mlk, qawanted, testcase
Product: Core
Classification: Components
Component: XUL (show other bugs)
: Trunk
: x86 Mac OS X
: -- major (vote)
: ---
Assigned To: Olli Pettay [:smaug]
:
: Neil Deakin
Mentors:
Depends on: 368573
Blocks: 344486 framedest 387033
  Show dependency treegraph
 
Reported: 2007-08-28 22:39 PDT by Jesse Ruderman
Modified: 2008-07-31 03:25 PDT (History)
8 users (show)
dveditz: blocking1.8.1.8+
jruderman: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (reload to see the assertions) (491 bytes, application/xhtml+xml)
2007-08-28 22:39 PDT, Jesse Ruderman
no flags Details
proposed patch (4.15 KB, patch)
2007-08-29 04:20 PDT, Olli Pettay [:smaug]
roc: review+
roc: superreview+
roc: approval1.9+
Details | Diff | Splinter Review

Description Jesse Ruderman 2007-08-28 22:39:20 PDT
Created attachment 278729 [details]
testcase (reload to see the assertions)

*Reloading* the testcase triggers:

###!!! ASSERTION: post-reflow queues not empty.  This means we're leaking: 'mFirstCallbackEventRequest == nsnull && mLastCallbackEventRequest == nsnull', file /Users/jruderman/trunk/mozilla/layout/base/nsPresShell.cpp, line 1402

###!!! ASSERTION: Some objects allocated with AllocateFrame were not freed: 'mFrameCount == 0', file /Users/jruderman/trunk/mozilla/layout/base/nsPresShell.cpp, line 673

I'm marking this bug as major because being able to test for the "Some objects allocated with AllocateFrame were not freed" assertion is important for detecting a class of memory safety bugs.
Comment 1 Olli Pettay [:smaug] 2007-08-29 04:20:43 PDT
Created attachment 278751 [details] [diff] [review]
proposed patch

Sorry, my mistake.
Better to post the callback when reflowing, then it gets called always and there
is no need to cancel it.
Comment 2 Daniel Veditz [:dveditz] 2007-09-24 11:58:31 PDT
qawanted: verify this doesn't regress on the 1.8 branch after bug 387033 lands
Comment 3 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-10-04 15:41:26 PDT
I can't really verify this on the 1.8 branch.
My debug 1.8 branch builds are from before this patch was checked in, but I don't get any assertion when reloading the testcase with those.
Comment 4 Jesse Ruderman 2007-12-19 15:56:39 PST
Crashtest checked in.

Note You need to log in before you can comment on or make changes to this bug.