Closed Bug 394128 Opened 13 years ago Closed 4 years ago

Add toolkit version to update data returned.

Categories

(AUS Graveyard :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX
4.x (triaged)

People

(Reporter: robert.strong.bugs, Assigned: morgamic)

References

Details

Bug 299716 landed to support extension compatibility with versions of the toolkit. To support displaying incompatible add-ons that use a toolkit version for compatibility we need the app update information to include the version of the toolkit in the same way that it provides the app version.
Flags: blocking-firefox3?
As I understand this (and I might be wrong!) without fixing this issue a user might be erroneously told that an add-on update will be compatible when, in fact, it won't. So that user might update their add-on, and then still see the "add-on incompatible" message.

I'm OK with not blocking if that understanding is correct. If this can lead to busted add-ons, though, or potentially incompatible add-ons being loaded, then please re-nominate.
Flags: blocking-firefox3? → blocking-firefox3-
No it is the opposite, the user might not be told that some of their add-ons will be disabled with the update re-requesting on this basis, but I don't really think it should be blocking. As far as I know we can potentially add this after the Firefox release, there is no code change to Firefox that I know of.
Flags: blocking-firefox3- → blocking-firefox3?
I agree, I don't think this blocks the release of Firefox 3.

morgamic/clouserw: how should we be marking these web-tools bugs which have a significant effect on the product? In this case, it's not a blocker, but is there any way of flagging it as really important?
Flags: blocking-firefox3? → blocking-firefox3-
Should be fixed when bug 459972 is fixed
Depends on: 459972
No longer needed.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.