Print messages fails in SeaMonkey MailNews (Build ID: 2007082803)

VERIFIED FIXED in seamonkey2.0a1

Status

SeaMonkey
MailNews: Message Display
--
major
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Tobias Fischer, Assigned: Bruno 'Aqualon' Escherl)

Tracking

({regression})

Trunk
seamonkey2.0a1
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007082803 Mnenhy/0.7.5.20003 SeaMonkey/2.0a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007082803 Mnenhy/0.7.5.20003 SeaMonkey/2.0a1pre

Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a8pre) Gecko/2007082803 Mnenhy/0.7.5.20003 SeaMonkey/2.0a1pre
printing Messages from MailNews fails, even from Printer-Icon or Ctrl-P. 

Error-Console throws:

Error: PrintUtils is not defined
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 1652

Printing works fine with SM-Build 2007082702. 


Reproducible: Always

Steps to Reproduce:
1. Install or unzip SeaMonkey-Trunk-Build 20082803
2. Start MailNews and select an Message
3. Try to print Message using Ctrl-P or Click on Icon
Actual Results:  
Nothing happens, exept of Error in Error-Console, see above

Expected Results:  
Printer Dialog should appear.

Think this was an Regression in SeaMonkey from Checkin for Bug 387247 
Thunderbird Trunk was not affected, I have tried TB Tinderbox-Build 2007082801 and printing messages will work there.
(Reporter)

Updated

11 years ago
Depends on: 387247
Keywords: regression
Version: unspecified → Trunk
(Reporter)

Comment 1

11 years ago
This was confirmed on Linux too with the same Error-Message, so I change OS to "All". Thanks to Hartmut Figge in d.c.s.m.nightly-builds.
OS: Windows XP → All

Comment 2

11 years ago
Does print preview work?
Looks like we forgot to update mailWindowOverlay.xul in SeaMonkey:

http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/mailnews/base/resources/content/mailWindowOverlay.xul&rev=1.334&mark=74#74

(I can't actually generate a patch at the current time, so someone please do)
Assignee: general → mail
Component: General → MailNews: Main Mail Window
QA Contact: general
(Reporter)

Comment 4

11 years ago
(In reply to comment #2)
No, print preview wont work, same message in Error-Console:

Error: PrintUtils is not defined
Source File: chrome://messenger/content/mailWindowOverlay.js
Line: 1652
(Assignee)

Comment 5

11 years ago
Created attachment 278761 [details] [diff] [review]
use printUtils.js in mailWindowOverlay.xul

Patch updates mailWindowOverlay.xul to use toolkit's printUtil.js
Assignee: mail → aqualon
Status: NEW → ASSIGNED
Attachment #278761 - Flags: superreview?(neil)
Attachment #278761 - Flags: review?(iann_bugzilla)

Comment 6

11 years ago
Comment on attachment 278761 [details] [diff] [review]
use printUtils.js in mailWindowOverlay.xul

KaiRo says that this is part of philor's patch that he somehow didn't check in, naughty boy ;-)
Attachment #278761 - Flags: superreview?(neil)

Comment 7

11 years ago
Comment on attachment 278761 [details] [diff] [review]
use printUtils.js in mailWindowOverlay.xul

OK, so philor says that he missed this from his original patch by mistake, so r+sr=me in that case.
Attachment #278761 - Flags: review?(iann_bugzilla) → review+
mailnews/base/resources/content/mailWindowOverlay.xul 1.335

Thanks for covering for my sloppiness, and sorry about the day without printing.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Target Milestone: --- → seamonkey2.0alpha
(Reporter)

Comment 9

11 years ago
Marking Verified=Fixed now, using SeaMonkey Win32 2007083002-Nightly-Build. 

Thanks to all for your fast work, and who cares about oneandahalfday without printing messages?
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.