View source code differs from File->Save Page As... on IDN url.

VERIFIED FIXED

Status

()

Core
Networking: Cache
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Jarl Friis, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.1 (like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); da-DK; rv:1.8.0.10) Gecko/20060911 SUSE/1.5.0.10-0.2 Firefox/1.5.0.10

I have installed MediaWiki 1.6.10 on the mentioned URL.

In an attempt to locate the anoying artifact that is show on the URL, I discovered that the View Source Code (CTRL+U) differes significantly from the Save Page As... (CTRL+S). When I write significantly I mean other that the obvious url-rewrites made to use CSS files in a local directory named like the local filename (chosen in Save Page As...).

The noticable difference is the following:
The View source code shows the following:

<div class="printfooter">
Hentet fra "<a href="http://www.xn--farumskovbrnehave-90b.dk/wiki/index.php?title=Forside">http://www.xn--farumskovbrnehave-90b.dk/wiki/index.php?title=Forside</a>"</div>

Whereas the the Save Page As... file contains the errorprone content:
<div class="printfooter">
Hentet fra "<a href="http://www.xn-->http://www.xn--farumskovbrnehave-90b.dk/wiki/index.php?title=Forside"</div>

It seems like gecko is actually trying to render the error-prone HTML.

The error-prone HTML seems to be what firefox has somehow dug up from it's own cache mechanism.

I can only reproduce this on an url on an IDN domain.

I have used wireshark (ethereal) to see what HTML is transfered. I cannot see that the error-prone HTML is ever transfered. The error-prone HTML must come from the firefox cache.

Reproducible: Always

Steps to Reproduce:
Load the page twice.

You can force firefox (gecko) to render the real HTML by appending "&action=purge" to end of URL.
Actual Results:  
incorrect (cached, I believe) HTML is rendered.

Expected Results:  
same HTML should be rendered even when from cache.

I have also seen this in a newer Firefox (on linux) and also on an even newer firefox on windows.
(Reporter)

Comment 1

10 years ago
The problem is no longer reproducable on latest Firefox (2.0.0.6)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.