'subscript'/'superscript' commands do not use css styles in DesignMode

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
11 years ago
6 years ago

People

(Reporter: kevin.heart, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070723 Iceweasel/2.0.0.6 (Debian-2.0.0.6-0etch1)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007082201 SeaMonkey/2.0a1pre

'subscript' command does not use css styles in DesignMode when format of generated content is set to css styles.

Reproducible: Always

Steps to Reproduce:
1. open the test page
Actual Results:  
Rich text editing function: "subscript" does not use CSS styles when
format of generated content is set to CSS styles by 'styleWithCSS' or 'useCSS'
command.


Expected Results:  
Generated content by function "subscript" uses CSS styles.
(Reporter)

Comment 1

11 years ago
Created attachment 278947 [details]
test page

test page

Updated

11 years ago
Status: UNCONFIRMED → NEW
Component: General → Editor
Ever confirmed: true
Product: Mozilla Application Suite → Core
Version: unspecified → Trunk

Updated

11 years ago
Blocks: 424615
Assignee: general → nobody
QA Contact: general → editor
This is per spec:

http://dvcs.w3.org/hg/editing/raw-file/tip/editing.html#forcing-the-value-of-a-node

See the steps that say

"""
If command is "subscript" or "superscript" and new value is "subscript", let new parent be the result of calling createElement("sub") on the ownerDocument of node.

If command is "subscript" or "superscript" and new value is "superscript", let new parent be the result of calling createElement("sup") on the ownerDocument of node.
"""

This is independent of the CSS styling flag (= styleWithCSS/useCSS).  If you click the "View comments" button, you'll find

"""
We always use sup/sub elements, even in CSS mode, following Gecko and contradicting WebKit. This is because <span value="vertical-align: sub/super">, the obvious equivalent (and what WebKit uses), behaves quite differently: it doesn't reduce font-size, which is ugly. WebKit's behavior is a bug anyway.
"""

The word "bug" links to https://bugs.webkit.org/show_bug.cgi?id=11089>.  WebKit behaves as requested but it causes sites to behave incorrectly, because the font size doesn't get changed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
Summary: 'subscript' command does not use css styles in DesignMode → 'subscript'/'superscript' commands do not use css styles in DesignMode
Duplicate of this bug: 394305
You need to log in before you can comment on or make changes to this bug.