Delete button in Bookmark This Page dialog is misleading

VERIFIED INVALID

Status

()

VERIFIED INVALID
11 years ago
9 years ago

People

(Reporter: stephen, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a8pre) Gecko/2007083004 Minefield/3.0a8pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a8pre) Gecko/2007083004 Minefield/3.0a8pre

The dialog that comes up after selecting Bookmark This Page command from Bookmarks menu contains 2 buttons. One is labeled "Delete" and the other "Done."

The Delete button should be labeled "Cancel".

Reproducible: Always

Steps to Reproduce:
1. Go to any web page.
2. Select "Bookmark This Page..." command from Bookmarks menu.
Actual Results:  
Add bookmark dialog shows up with a Delete button

Expected Results:  
The button should be labeled "Cancel"
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: Macintosh → PC
Component: Bookmarks → Places
QA Contact: bookmarks → places

Comment 1

11 years ago
This dialog will be redone in bug 393509.
Blocks: 385266

Updated

11 years ago
Duplicate of this bug: 404144
actually no more valid i guess
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Indeed. We have Cancel and Done now. Verified.
Status: RESOLVED → VERIFIED
Hardware: PC → All
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.